# CVE-2022-23116: Agent-to-controller security bypass in Jenkins Conjur Secrets Plugin allows decrypting secrets

> Attackers controlling agent processes can decrypt Jenkins secrets obtained via other means, exposing sensitive credentials.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Jan 2022
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-g7fx-mmjc-r7gv

## What is CVE-2022-23116?

CVE-2022-23116 is a high-severity vulnerability in Jenkins Conjur Secrets Plugin, published on 12 Jan 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Jenkins Conjur Secrets Plugin 1.0.9 and earlier implements functionality that allows attackers able to control agent processes to decrypt secrets stored in Jenkins obtained through another method.

Weakness: CWE-311 (Missing Encryption of Sensitive Data)

## Which versions are affected by CVE-2022-23116?

2 open source packages ship an affected version, including org.conjur.jenkins:conjur-credentials. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.conjur.jenkins:conjur-credentials` | Maven | All versions | 1.0.10 |
| `org.conjur.jenkins:conjur-credentials` | Maven | All versions | 1.0.10 |

Products: Jenkins Conjur Secrets.

## How do I fix CVE-2022-23116?

Upgrade org.conjur.jenkins:conjur-credentials to 1.0.10 or later.

## Is CVE-2022-23116 being exploited?

There is no known exploitation of CVE-2022-23116 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins Conjur Secrets Plugin

- [CVE-2022-23117](https://insights.sbomify.com/CVE-2022-23117/): Agent-to-controller security bypass in Jenkins Conjur Secrets Plugin allows retrieving all credentials (high 7.5)
- [CVE-2022-25190](https://insights.sbomify.com/CVE-2022-25190/): Missing permission check in Jenkins Conjur Secrets Plugin allows enumerating credentials IDs (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-23116 and fix it if it is affected.

What it is: CVE-2022-23116 is a high-severity vulnerability in Jenkins Conjur Secrets Plugin, published on 12 Jan 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-23116 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.conjur.jenkins:conjur-credentials (Maven): affected all versions; fixed in 1.0.10
- org.conjur.jenkins:conjur-credentials (Maven): affected all versions; fixed in 1.0.10

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-23116/ (Markdown: https://insights.sbomify.com/CVE-2022-23116/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-23116
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-23116
- OSV: https://osv.dev/vulnerability/CVE-2022-23116

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-23116/
Summaries are generated and may contain mistakes; the official description above is the record.
