# CVE-2022-23206: Server-Side Request Forgery in Traffic Ops endpoint POST /user/login/oauth

> An unprivileged user can exploit an SSRF vulnerability in the OAuth login endpoint to scan internal ports reachable by the Traffic Ops server.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Feb 2022
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-wp47-9r3h-xfgq, GO-2022-0585

## What is CVE-2022-23206?

CVE-2022-23206 is a high-severity server-side request forgery vulnerability in Apache Traffic Control, published on 6 Feb 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In Apache Traffic Control Traffic Ops prior to 6.1.0 or 5.1.6, an unprivileged user who can reach Traffic Ops over HTTPS can send a specially-crafted POST request to /user/login/oauth to scan a port of a server that Traffic Ops can reach.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2022-23206?

5 open source packages ship an affected version, including github.com/apache/trafficcontrol. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/apache/trafficcontrol` | Go | All versions | 5.1.6+incompatible, 6.1.0+incompatible |
| `github.com/apache/trafficcontrol` | Go | All versions | 5.1.6 |
| `github.com/apache/trafficcontrol` | Go | All versions | 5.1.6 |
| `github.com/apache/trafficcontrol` | Go | From 6.0.0 | 6.1.0 |
| `github.com/apache/trafficcontrol` | Go | From 6.0.0 | 6.1.0 |

Products: Apache Traffic Control.

## How do I fix CVE-2022-23206?

Upgrade github.com/apache/trafficcontrol to a fixed version for your release line: 5.1.6+incompatible, 6.1.0+incompatible, 5.1.6 or 6.1.0.

## Is CVE-2022-23206 being exploited?

There is no known exploitation of CVE-2022-23206 in the wild and no public exploit code.

## Other vulnerabilities in Apache Traffic Control

- [CVE-2024-45387](https://insights.sbomify.com/CVE-2024-45387/): Apache Traffic Control: SQL Injection in Traffic Ops endpoint PUT deliveryservice_request_comments (critical 9.9)
- [CVE-2021-43350](https://insights.sbomify.com/CVE-2021-43350/): LDAP filter injection vulnerability in Traffic Ops (critical 9.8)
- [CVE-2019-12405](https://insights.sbomify.com/CVE-2019-12405/): Improper Authentication in Apache Traffic Control (critical 9.8)
- [CVE-2025-61581](https://insights.sbomify.com/CVE-2025-61581/): Apache Traffic Control: ReDoS issue in Traffic Router configuration (high 7.5)
- [CVE-2017-7670](https://insights.sbomify.com/CVE-2017-7670/): Apache Traffic Control vulnerable to Slowloris-style Denial of Service attack (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-23206 and fix it if it is affected.

What it is: CVE-2022-23206 is a high-severity server-side request forgery vulnerability in Apache Traffic Control, published on 6 Feb 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-23206 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/apache/trafficcontrol (Go): affected all versions; fixed in 5.1.6+incompatible, 6.1.0+incompatible
- github.com/apache/trafficcontrol (Go): affected all versions; fixed in 5.1.6
- github.com/apache/trafficcontrol (Go): affected all versions; fixed in 5.1.6
- github.com/apache/trafficcontrol (Go): affected from 6.0.0; fixed in 6.1.0
- github.com/apache/trafficcontrol (Go): affected from 6.0.0; fixed in 6.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-23206/ (Markdown: https://insights.sbomify.com/CVE-2022-23206/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-23206
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-23206
- OSV: https://osv.dev/vulnerability/CVE-2022-23206

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-23206/
Summaries are generated and may contain mistakes; the official description above is the record.
