{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-23220 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2022-23220 is a high-severity authentication bypass vulnerability in n/a, published on 21 Jan 2022. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-23220 and fix it if it is affected.\n\nWhat it is: CVE-2022-23220 is a high-severity authentication bypass vulnerability in n/a, published on 21 Jan 2022. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-23220 in the wild and no public exploit code.\n\nAffected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-23220/ (Markdown: https://insights.sbomify.com/CVE-2022-23220/index.md)","id":"CVE-2022-23220","markdown":"https://insights.sbomify.com/CVE-2022-23220/index.md","name":"CVE-2022-23220","record":{"aliases":["DEBIAN-CVE-2022-23220","DSA-5052-1","GHSA-crwr-hcrm-rq6f","UBUNTU-CVE-2022-23220","USN-5249-1","openSUSE-SU-2024:11774-1"],"analysis":{"component_type":"operating_system","fix_type":"upgrade","impacts":["code_execution","privilege_escalation"],"network_reachable":"adjacent_or_local","non_default_config":true,"product_category":"Linux USB viewer","requires_auth":"low_privilege","summary":"Local users can execute arbitrary code as root via USBView due to misconfigured Polkit settings allowing unauthenticated pkexec usage.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"usbview","vendor":"usbview_project"}],"cvss":{"score":7.8,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-306","name":"Missing Authentication for Critical Functionality"}],"description":"USBView 2.1 before 2.2 allows some local users (e.g., ones logged in via SSH) to execute arbitrary code as root because certain Polkit settings (e.g., allow_any=yes) for pkexec disable the authentication requirement. Code execution can, for example, use the --gtk-module option. This affects Ubuntu, Debian, and Gentoo.","ecosystems":["openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Auth bypass in n/a","id":"CVE-2022-23220","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"auth_bypass","year":"2022"},"n_packages":1,"n_references":5,"next":{"headline":"Arbitrary code execution in H2 Console","id":"CVE-2022-23221"},"packages":[{"ecosystem":"openSUSE:Tumbleweed","fixed":["3.0-1.1"],"introduced":["0"],"last_affected":[],"package":"usbview","purl":"pkg:rpm/opensuse/usbview\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2024:11774-1"}],"prev":{"headline":"Memory corruption in n/a","id":"CVE-2022-23219"},"products":["n/a"],"published":"2022-01-21","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["n/a"]},"summary":"Local users can execute arbitrary code as root via USBView due to misconfigured Polkit settings allowing unauthenticated pkexec usage.","url":"https://insights.sbomify.com/CVE-2022-23220/"}