# CVE-2022-23221: Arbitrary code execution in H2 Console

> Remote attackers can execute arbitrary code in H2 Console via crafted JDBC URLs when specific settings are enabled.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Jan 2022
- **Updated:** 5 May 2025
- **Also known as:** CLSA-2026-1793128778, DEBIAN-CVE-2022-23221, GHSA-45hx-wfhj-473x, UBUNTU-CVE-2022-23221

## What is CVE-2022-23221?

CVE-2022-23221 is a critical code injection vulnerability in Debian Debian Linux, published on 19 Jan 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

H2 Console before 2.1.210 allows remote attackers to execute arbitrary code via a jdbc:h2:mem JDBC URL containing the IGNORE_UNKNOWN_SETTINGS=TRUE;FORBID_CREATION=FALSE;INIT=RUNSCRIPT substring, a different vulnerability than CVE-2021-42392.

Weakness: CWE-88 (Improper Neutralization of Argument Delimiters in a Command)

## Which versions are affected by CVE-2022-23221?

2 open source packages ship an affected version, including com.h2database:h2. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.h2database:h2` | Maven | All versions | 2.1.210 |
| `com.h2database:h2` | Maven | All versions | 2.1.210 |

Products: Debian Debian Linux, H2database H2, Oracle Communications Cloud Native Core Console.

## How do I fix CVE-2022-23221?

Upgrade com.h2database:h2 to 2.1.210 or later.

## Is CVE-2022-23221 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-23221 exists.

Public exploit code:

- vulhub/H2-database/CVE-2022-23221 (github_poc): https://github.com/straightSang/H2-database-CVE-2022-23221
- Vulhub h2database/CVE-2022-23221: H2 Database Console JDBC URL RCE (CVE-2022-23221), run with Isoloom (github_poc): https://github.com/CyberCTF/vulhub-h2database-cve-2022-23221

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-23221 and fix it if it is affected.

What it is: CVE-2022-23221 is a critical code injection vulnerability in Debian Debian Linux, published on 19 Jan 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-23221 exists.

Affected packages and fixed versions:
- com.h2database:h2 (Maven): affected all versions; fixed in 2.1.210
- com.h2database:h2 (Maven): affected all versions; fixed in 2.1.210

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-23221/ (Markdown: https://insights.sbomify.com/CVE-2022-23221/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-23221
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-23221
- OSV: https://osv.dev/vulnerability/CVE-2022-23221

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-23221/
Summaries are generated and may contain mistakes; the official description above is the record.
