{"answers":{"affected":"2 open source packages ship an affected version, including org.apache.shenyu:shenyu-common. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-23223 in the wild and no public exploit code.","fix":"Upgrade org.apache.shenyu:shenyu-common to 2.4.2 or later.","what":"CVE-2022-23223 is a high-severity vulnerability in Apache ShenYu (incubating), published on 25 Jan 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-23223 and fix it if it is affected.\n\nWhat it is: CVE-2022-23223 is a high-severity vulnerability in Apache ShenYu (incubating), published on 25 Jan 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-23223 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.apache.shenyu:shenyu-common (Maven): affected from 2.4.0; fixed in 2.4.2\n- org.apache.shenyu:shenyu-common (Maven): affected from 2.4.0; fixed in 2.4.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-23223/ (Markdown: https://insights.sbomify.com/CVE-2022-23223/index.md)","id":"CVE-2022-23223","markdown":"https://insights.sbomify.com/CVE-2022-23223/index.md","name":"CVE-2022-23223","record":{"aliases":["GHSA-7wq4-89xx-g62j"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Apache ShenYu gateway","requires_auth":"none","summary":"An exposed endpoint in Apache ShenYu allows attackers to read all user passwords, requiring an upgrade to secure credentials.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"shenyu","vendor":"apache"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-522","name":"Insufficiently Protected Credentials"}],"description":"On Apache ShenYu versions 2.4.0 and 2.4.1, and endpoint existed that disclosed the passwords of all users. Users are recommended to upgrade to version 2.4.2 or later.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Apache ShenYu Password leakage","id":"CVE-2022-23223","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"information_disclosure","year":"2022"},"n_packages":2,"n_references":3,"next":{"headline":"NUUO NVRmini2 Devices Missing Authentication Vulnerability","id":"CVE-2022-23227"},"packages":[{"ecosystem":"Maven","fixed":["2.4.2"],"introduced":["2.4.0"],"last_affected":[],"package":"org.apache.shenyu:shenyu-common","purl":null,"source":"GHSA-7wq4-89xx-g62j"},{"ecosystem":"Maven","fixed":["2.4.2"],"introduced":["2.4.0"],"last_affected":[],"package":"org.apache.shenyu:shenyu-common","purl":"pkg:maven/org.apache.shenyu/shenyu-common","source":"GHSA-7wq4-89xx-g62j"}],"prev":{"headline":"Privilege escalation in n/a","id":"CVE-2022-23222"},"products":["Apache ShenYu (incubating)"],"published":"2022-01-25","related":[{"cvss_score":9.8,"headline":"Apache ShenYu 2.4.1 Groovy Code Injection \u0026 SpEL Injection","id":"CVE-2021-45029","kev_date_added":null,"published":"2022-01-25"},{"cvss_score":9.8,"headline":"Apache ShenYu Admin bypass JWT authentication","id":"CVE-2021-37580","kev_date_added":null,"published":"2021-11-16"},{"cvss_score":9.1,"headline":"Apache ShenYu 2.4.1 Improper access control","id":"CVE-2022-23944","kev_date_added":null,"published":"2022-01-25"},{"cvss_score":8.8,"headline":"Apache ShenYu Admin ultra vires","id":"CVE-2022-42735","kev_date_added":null,"published":"2023-02-15"},{"cvss_score":8.8,"headline":"Apache ShenYu Admin Improper Privilege Management","id":"CVE-2022-37435","kev_date_added":null,"published":"2022-09-01"},{"cvss_score":7.5,"headline":"Apache ShenYu (incubating) Regular expression denial of service","id":"CVE-2022-26650","kev_date_added":null,"published":"2022-05-17"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["Apache Software Foundation"]},"summary":"An exposed endpoint in Apache ShenYu allows attackers to read all user passwords, requiring an upgrade to secure credentials.","url":"https://insights.sbomify.com/CVE-2022-23223/"}