# CVE-2022-23340: Joplin Vulnerable to Code Injection

> Remote attackers can execute system commands via malicious code in user search results within the Joplin application.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Feb 2022
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-8478-53pv-jxvm

## What is CVE-2022-23340?

CVE-2022-23340 is a critical command injection vulnerability in n/a, published on 8 Feb 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Joplin 2.6.10 allows remote attackers to execute system commands through malicious code in user search results.

## Which versions are affected by CVE-2022-23340?

2 open source packages ship an affected version, including joplin. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `joplin` | npm | All versions | 2.7.1 |
| `joplin` | npm | All versions | 2.7.1 |

Products: Joplin Project Joplin.

## How do I fix CVE-2022-23340?

Upgrade joplin to 2.7.1 or later.

## Is CVE-2022-23340 being exploited?

There is no known exploitation of CVE-2022-23340 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2024-40643](https://insights.sbomify.com/CVE-2024-40643/): Joplin has a parsing error leading to Cross-site Scripting (XSS) (critical 9.7)
- [CVE-2023-45673](https://insights.sbomify.com/CVE-2023-45673/): Arbitrary code execution on click of PDF links in Joplin (high 8.9)
- [CVE-2025-27134](https://insights.sbomify.com/CVE-2025-27134/): Privilege escalation in Joplin server via user patch endpoint (high 8.8)
- [CVE-2023-37898](https://insights.sbomify.com/CVE-2023-37898/): Safe mode Cross-site Scripting (XSS) vulnerability in Joplin (high 8.2)
- [CVE-2023-38506](https://insights.sbomify.com/CVE-2023-38506/): Cross-site Scripting (XSS) when pasting HTML into the rich text editor in Joplin (high 8.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-23340 and fix it if it is affected.

What it is: CVE-2022-23340 is a critical command injection vulnerability in n/a, published on 8 Feb 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-23340 in the wild and no public exploit code.

Affected packages and fixed versions:
- joplin (npm): affected all versions; fixed in 2.7.1
- joplin (npm): affected all versions; fixed in 2.7.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-23340/ (Markdown: https://insights.sbomify.com/CVE-2022-23340/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-23340
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-23340
- OSV: https://osv.dev/vulnerability/CVE-2022-23340

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-23340/
Summaries are generated and may contain mistakes; the official description above is the record.
