# CVE-2022-23435: android-gif-drawable vulerable to denial of service due to unrestricted comment length

> An attacker can cause a denial of service in applications using the android-gif-drawable library by providing a GIF with an excessively long comment.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Jan 2022
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-3mm4-w7v6-4rhv

## What is CVE-2022-23435?

CVE-2022-23435 is a high-severity denial of service vulnerability in n/a, published on 19 Jan 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

decoding.c in android-gif-drawable before 1.2.24 does not limit the maximum length of a comment, leading to denial of service.

## Which versions are affected by CVE-2022-23435?

2 open source packages ship an affected version, including pl.droidsonroids.gif:android-gif-drawable. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pl.droidsonroids.gif:android-gif-drawable` | Maven | All versions | 1.2.24 |
| `pl.droidsonroids.gif:android-gif-drawable` | Maven | All versions | 1.2.24 |

Products: Android-Gif-Drawable Project Android-Gif-Drawable.

## How do I fix CVE-2022-23435?

Upgrade pl.droidsonroids.gif:android-gif-drawable to 1.2.24 or later.

## Is CVE-2022-23435 being exploited?

There is no known exploitation of CVE-2022-23435 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2019-11932](https://insights.sbomify.com/CVE-2019-11932/): android-gif-drawable Double Free vulnerability (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-23435 and fix it if it is affected.

What it is: CVE-2022-23435 is a high-severity denial of service vulnerability in n/a, published on 19 Jan 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-23435 in the wild and no public exploit code.

Affected packages and fixed versions:
- pl.droidsonroids.gif:android-gif-drawable (Maven): affected all versions; fixed in 1.2.24
- pl.droidsonroids.gif:android-gif-drawable (Maven): affected all versions; fixed in 1.2.24

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-23435/ (Markdown: https://insights.sbomify.com/CVE-2022-23435/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-23435
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-23435
- OSV: https://osv.dev/vulnerability/CVE-2022-23435

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-23435/
Summaries are generated and may contain mistakes; the official description above is the record.
