# CVE-2022-23452: openstack-barbican Denial of Service vulnerability

> An admin user can add secrets to other project containers, allowing resource consumption and denial of service in OpenStack Barbican.

- **Severity:** Medium 4.9 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Sep 2022
- **Updated:** 3 Aug 2024
- **Also known as:** DEBIAN-CVE-2022-23452, GHSA-6p2h-rjj7-2j63, PYSEC-2026-785, UBUNTU-CVE-2022-23452

## What is CVE-2022-23452?

CVE-2022-23452 is a medium-severity missing authorization vulnerability in openstack/barbican, published on 1 Sep 2022. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

An authorization flaw was found in openstack-barbican, where anyone with an admin role could add secrets to a different project container. This flaw allows an attacker on the network to consume protected resources and cause a denial of service.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2022-23452?

3 open source packages ship an affected version, including barbican. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `barbican` | PyPI | All versions | 14.0.0 |
| `barbican` | PyPI | All versions | 14.0.0 |
| `barbican` | PyPI | All versions | 14.0.0 |

Products: Openstack Barbican, Redhat Openstack Platform.

## How do I fix CVE-2022-23452?

Upgrade barbican to 14.0.0 or later.

## Is CVE-2022-23452 being exploited?

There is no known exploitation of CVE-2022-23452 in the wild and no public exploit code.

## Other vulnerabilities in openstack/barbican

- [CVE-2022-23451](https://insights.sbomify.com/CVE-2022-23451/): Barbican authorization flaw before v14.0.0 (high 8.1)
- [CVE-2023-1633](https://insights.sbomify.com/CVE-2023-1633/): Insecure barbican configuration file leaking credential (medium 6.6)
- [CVE-2023-1636](https://insights.sbomify.com/CVE-2023-1636/): Incomplete container isolation (medium 6.0)
- [CVE-2022-3100](https://insights.sbomify.com/CVE-2022-3100/): Auth bypass in Red Hat OpenStack Platform (medium 5.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-23452 and fix it if it is affected.

What it is: CVE-2022-23452 is a medium-severity missing authorization vulnerability in openstack/barbican, published on 1 Sep 2022. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-23452 in the wild and no public exploit code.

Affected packages and fixed versions:
- barbican (PyPI): affected all versions; fixed in 14.0.0
- barbican (PyPI): affected all versions; fixed in 14.0.0
- barbican (PyPI): affected all versions; fixed in 14.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-23452/ (Markdown: https://insights.sbomify.com/CVE-2022-23452/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-23452
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-23452
- OSV: https://osv.dev/vulnerability/CVE-2022-23452

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-23452/
Summaries are generated and may contain mistakes; the official description above is the record.
