# CVE-2022-23457: Path Traversal in ESAPI

> Attackers can bypass directory path validation checks in the OWASP ESAPI library, potentially accessing unauthorized files or directories.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Apr 2022
- **Updated:** 3 Nov 2025
- **Also known as:** DEBIAN-CVE-2022-23457, GHSA-8m5h-hrqm-pxm2, UBUNTU-CVE-2022-23457

## What is CVE-2022-23457?

CVE-2022-23457 is a high-severity path traversal vulnerability in Netapp Active Iq Unified Manager, published on 25 Apr 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

ESAPI (The OWASP Enterprise Security API) is a free, open source, web application security control library. Prior to version 2.3.0.0, the default implementation of `Validator.getValidDirectoryPath(String, String, File, boolean)` may incorrectly treat the tested input string as a child of the specified parent directory. This potentially could allow control-flow bypass checks to be defeated if an attack can specify the entire string representing the 'input' path. This vulnerability is patched in release 2.3.0.0 of ESAPI. As a workaround, it is possible to write one's own implementation of the Validator interface. However, maintainers do not recommend this.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2022-23457?

2 open source packages ship an affected version, including org.owasp.esapi:esapi. It affects 4 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.owasp.esapi:esapi` | Maven | All versions | 2.3.0.0 |
| `org.owasp.esapi:esapi` | Maven | All versions | 2.3.0.0 |

Products: Netapp Active Iq Unified Manager, Netapp Oncommand Workflow Automation, Oracle Weblogic Server, Owasp Enterprise Security Api.

## How do I fix CVE-2022-23457?

Upgrade org.owasp.esapi:esapi to 2.3.0.0 or later.

## Is CVE-2022-23457 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-23457 exists.

Public exploit code:

- https://github.com/shoucheng3/ESAPI__esapi-java-legacy_CVE-2022-23457_2-2-3-1 (github_poc): https://github.com/shoucheng3/ESAPI__esapi-java-legacy_CVE-2022-23457_2-2-3-1

## Other vulnerabilities in Netapp Active Iq Unified Manager

- [CVE-2022-31692](https://insights.sbomify.com/CVE-2022-31692/): Spring Security authorization rules can be bypassed via forward or include dispatcher types (critical 9.8)
- [CVE-2022-2526](https://insights.sbomify.com/CVE-2022-2526/): Use after free in systemd-resolved (critical 9.8)
- [CVE-2022-22978](https://insights.sbomify.com/CVE-2022-22978/): Authorization bypass in Spring Security (critical 9.8)
- [CVE-2021-22931](https://insights.sbomify.com/CVE-2021-22931/): Code injection in Node (critical 9.8)
- [CVE-2018-2938](https://insights.sbomify.com/CVE-2018-2938/): Code injection in Java (critical 9.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-23457 and fix it if it is affected.

What it is: CVE-2022-23457 is a high-severity path traversal vulnerability in Netapp Active Iq Unified Manager, published on 25 Apr 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-23457 exists.

Affected packages and fixed versions:
- org.owasp.esapi:esapi (Maven): affected all versions; fixed in 2.3.0.0
- org.owasp.esapi:esapi (Maven): affected all versions; fixed in 2.3.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-23457/ (Markdown: https://insights.sbomify.com/CVE-2022-23457/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-23457
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-23457
- OSV: https://osv.dev/vulnerability/CVE-2022-23457

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-23457/
Summaries are generated and may contain mistakes; the official description above is the record.
