# CVE-2022-23458: Toast UI Grid vulnerable to Cross-site scripting

> An attacker can execute arbitrary scripts by pasting malicious content into editable cells of the Toast UI Grid component.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 22 Sep 2022
- **Updated:** 22 Apr 2025
- **Also known as:** GHSA-9rwj-9j2h-fhvm

## What is CVE-2022-23458?

CVE-2022-23458 is a medium-severity cross-site scripting vulnerability in nhn tui.grid, published on 22 Sep 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Toast UI Grid is a component to display and edit data. Versions prior to 4.21.3 are vulnerable to cross-site scripting attacks when pasting specially crafted content into editable cells. This issue was fixed in version 4.21.3. There are no known workarounds.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2022-23458?

2 open source packages ship an affected version, including tui-grid. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `tui-grid` | npm | All versions | 4.21.3 |
| `tui-grid` | npm | All versions | 4.21.3 |

Products: Nhn Toast Ui Grid.

## How do I fix CVE-2022-23458?

Upgrade tui-grid to 4.21.3 or later.

## Is CVE-2022-23458 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-23458 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-23458 and fix it if it is affected.

What it is: CVE-2022-23458 is a medium-severity cross-site scripting vulnerability in nhn tui.grid, published on 22 Sep 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-23458 exists.

Affected packages and fixed versions:
- tui-grid (npm): affected all versions; fixed in 4.21.3
- tui-grid (npm): affected all versions; fixed in 4.21.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-23458/ (Markdown: https://insights.sbomify.com/CVE-2022-23458/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-23458
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-23458
- OSV: https://osv.dev/vulnerability/CVE-2022-23458

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-23458/
Summaries are generated and may contain mistakes; the official description above is the record.
