{"answers":{"affected":"8 open source packages ship an affected version, including teler.app. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-23466 in the wild and no public exploit code.","fix":"Upgrade teler.app to a fixed version for your release line: 0.0.0-20221203202318-20f59eda2420, 1.2.3-0.20221203202318-20f59eda2420, 2.0.0-dev.2 or 2.0.0-rc.4.","what":"CVE-2022-23466 is a medium-severity cross-site scripting vulnerability in kitabisa teler, published on 6 Dec 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2022-23466 and fix it if it is affected.\n\nWhat it is: CVE-2022-23466 is a medium-severity cross-site scripting vulnerability in kitabisa teler, published on 6 Dec 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2022-23466 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- teler.app (Go): affected from 0.0.0-20220625162531-2289e90590a9; fixed in 0.0.0-20221203202318-20f59eda2420\n- teler.app (Go): affected from 0.0.0-20220625162531-2289e90590a9; fixed in 0.0.0-20221203202318-20f59eda2420\n- teler.app (Go): affected from 1.2.3-0.20220625162531-2289e90590a9; fixed in 1.2.3-0.20221203202318-20f59eda2420\n- teler.app (Go): affected from 1.2.3-0.20220625162531-2289e90590a9; fixed in 1.2.3-0.20221203202318-20f59eda2420\n- teler.app (Go): affected from 2.0.0-dev; fixed in 2.0.0-dev.2\n- teler.app (Go): affected from 2.0.0-dev; fixed in 2.0.0-dev.2\n- teler.app (Go): affected from 2.0.0-rc; fixed in 2.0.0-rc.4\n- teler.app (Go): affected from 2.0.0-rc; fixed in 2.0.0-rc.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-23466/ (Markdown: https://insights.sbomify.com/CVE-2022-23466/index.md)","id":"CVE-2022-23466","markdown":"https://insights.sbomify.com/CVE-2022-23466/index.md","name":"CVE-2022-23466","record":{"aliases":["GHSA-xr7p-8q82-878q"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Intrusion detection dashboard","requires_auth":"none","summary":"An attacker can execute arbitrary scripts in the teler dashboard via unsanitized log data, potentially compromising authenticated users.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"teler","vendor":"teler_project"}],"cvss":{"score":5.4,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"teler is an real-time intrusion detection and threat alert dashboard. teler prior to version 2.0.0-rc.4 is vulnerable to DOM-based cross-site scripting (XSS) in the teler dashboard. When teler requests messages from the event stream on the `/events` endpoint, the log data displayed on the dashboard are not sanitized. This only affects authenticated users and can only be exploited based on detected threats if the log contains a DOM scripting payload. This vulnerability has been fixed on version `v2.0.0-rc.4`. Users are advised to upgrade. There are no known workarounds for this vulnerability.","ecosystems":["Go"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"DOM-based cross-site scripting (XSS) in teler dashboard","id":"CVE-2022-23466","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Go","product":null,"products":[],"type":"xss","year":"2022"},"n_packages":8,"n_references":2,"next":{"headline":"Out of Bounds Read in OpenRazer Driver","id":"CVE-2022-23467"},"packages":[{"ecosystem":"Go","fixed":["0.0.0-20221203202318-20f59eda2420"],"introduced":["0.0.0-20220625162531-2289e90590a9"],"last_affected":[],"package":"teler.app","purl":null,"source":"GHSA-xr7p-8q82-878q"},{"ecosystem":"Go","fixed":["0.0.0-20221203202318-20f59eda2420"],"introduced":["0.0.0-20220625162531-2289e90590a9"],"last_affected":[],"package":"teler.app","purl":"pkg:golang/teler.app","source":"GHSA-xr7p-8q82-878q"},{"ecosystem":"Go","fixed":["1.2.3-0.20221203202318-20f59eda2420"],"introduced":["1.2.3-0.20220625162531-2289e90590a9"],"last_affected":[],"package":"teler.app","purl":null,"source":"GHSA-xr7p-8q82-878q"},{"ecosystem":"Go","fixed":["1.2.3-0.20221203202318-20f59eda2420"],"introduced":["1.2.3-0.20220625162531-2289e90590a9"],"last_affected":[],"package":"teler.app","purl":"pkg:golang/teler.app","source":"GHSA-xr7p-8q82-878q"},{"ecosystem":"Go","fixed":["2.0.0-dev.2"],"introduced":["2.0.0-dev"],"last_affected":[],"package":"teler.app","purl":null,"source":"GHSA-xr7p-8q82-878q"},{"ecosystem":"Go","fixed":["2.0.0-dev.2"],"introduced":["2.0.0-dev"],"last_affected":[],"package":"teler.app","purl":"pkg:golang/teler.app","source":"GHSA-xr7p-8q82-878q"},{"ecosystem":"Go","fixed":["2.0.0-rc.4"],"introduced":["2.0.0-rc"],"last_affected":[],"package":"teler.app","purl":null,"source":"GHSA-xr7p-8q82-878q"},{"ecosystem":"Go","fixed":["2.0.0-rc.4"],"introduced":["2.0.0-rc"],"last_affected":[],"package":"teler.app","purl":"pkg:golang/teler.app","source":"GHSA-xr7p-8q82-878q"}],"prev":{"headline":"SwiftTerm vulnerable to arbitrary command execution","id":"CVE-2022-23465"},"products":["teler"],"published":"2022-12-06","related":[{"cvss_score":5.9,"headline":"Denial of Service in teler","id":"CVE-2020-26213","kev_date_added":null,"published":"2020-11-06"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-23","vendors":["kitabisa"]},"summary":"An attacker can execute arbitrary scripts in the teler dashboard via unsanitized log data, potentially compromising authenticated users.","url":"https://insights.sbomify.com/CVE-2022-23466/"}