# CVE-2022-23466: DOM-based cross-site scripting (XSS) in teler dashboard

> An attacker can execute arbitrary scripts in the teler dashboard via unsanitized log data, potentially compromising authenticated users.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 6 Dec 2022
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-xr7p-8q82-878q

## What is CVE-2022-23466?

CVE-2022-23466 is a medium-severity cross-site scripting vulnerability in kitabisa teler, published on 6 Dec 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

teler is an real-time intrusion detection and threat alert dashboard. teler prior to version 2.0.0-rc.4 is vulnerable to DOM-based cross-site scripting (XSS) in the teler dashboard. When teler requests messages from the event stream on the `/events` endpoint, the log data displayed on the dashboard are not sanitized. This only affects authenticated users and can only be exploited based on detected threats if the log contains a DOM scripting payload. This vulnerability has been fixed on version `v2.0.0-rc.4`. Users are advised to upgrade. There are no known workarounds for this vulnerability.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2022-23466?

8 open source packages ship an affected version, including teler.app. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `teler.app` | Go | From 0.0.0-20220625162531-2289e90590a9 | 0.0.0-20221203202318-20f59eda2420 |
| `teler.app` | Go | From 0.0.0-20220625162531-2289e90590a9 | 0.0.0-20221203202318-20f59eda2420 |
| `teler.app` | Go | From 1.2.3-0.20220625162531-2289e90590a9 | 1.2.3-0.20221203202318-20f59eda2420 |
| `teler.app` | Go | From 1.2.3-0.20220625162531-2289e90590a9 | 1.2.3-0.20221203202318-20f59eda2420 |
| `teler.app` | Go | From 2.0.0-dev | 2.0.0-dev.2 |
| `teler.app` | Go | From 2.0.0-dev | 2.0.0-dev.2 |
| `teler.app` | Go | From 2.0.0-rc | 2.0.0-rc.4 |
| `teler.app` | Go | From 2.0.0-rc | 2.0.0-rc.4 |

Products: Teler Project Teler.

## How do I fix CVE-2022-23466?

Upgrade teler.app to a fixed version for your release line: 0.0.0-20221203202318-20f59eda2420, 1.2.3-0.20221203202318-20f59eda2420, 2.0.0-dev.2 or 2.0.0-rc.4.

## Is CVE-2022-23466 being exploited?

There is no known exploitation of CVE-2022-23466 in the wild and no public exploit code.

## Other vulnerabilities in kitabisa teler

- [CVE-2020-26213](https://insights.sbomify.com/CVE-2020-26213/): Denial of Service in teler (medium 5.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-23466 and fix it if it is affected.

What it is: CVE-2022-23466 is a medium-severity cross-site scripting vulnerability in kitabisa teler, published on 6 Dec 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-23466 in the wild and no public exploit code.

Affected packages and fixed versions:
- teler.app (Go): affected from 0.0.0-20220625162531-2289e90590a9; fixed in 0.0.0-20221203202318-20f59eda2420
- teler.app (Go): affected from 0.0.0-20220625162531-2289e90590a9; fixed in 0.0.0-20221203202318-20f59eda2420
- teler.app (Go): affected from 1.2.3-0.20220625162531-2289e90590a9; fixed in 1.2.3-0.20221203202318-20f59eda2420
- teler.app (Go): affected from 1.2.3-0.20220625162531-2289e90590a9; fixed in 1.2.3-0.20221203202318-20f59eda2420
- teler.app (Go): affected from 2.0.0-dev; fixed in 2.0.0-dev.2
- teler.app (Go): affected from 2.0.0-dev; fixed in 2.0.0-dev.2
- teler.app (Go): affected from 2.0.0-rc; fixed in 2.0.0-rc.4
- teler.app (Go): affected from 2.0.0-rc; fixed in 2.0.0-rc.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-23466/ (Markdown: https://insights.sbomify.com/CVE-2022-23466/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-23466
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-23466
- OSV: https://osv.dev/vulnerability/CVE-2022-23466

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-23466/
Summaries are generated and may contain mistakes; the official description above is the record.
