# CVE-2022-23469: Authorization header displayed in the debug logs

> Traefik exposes Authorization headers in debug logs, allowing attackers with log access to steal credentials.

- **Severity:** Low 3.5 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Dec 2022
- **Updated:** 22 Apr 2025
- **Also known as:** ECHO-463d-152a-b1b7, GHSA-h2ph-vhm7-g4hp, GO-2022-1154

## What is CVE-2022-23469?

CVE-2022-23469 is a low-severity vulnerability in Traefik Traefik, published on 8 Dec 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Traefik is an open source HTTP reverse proxy and load balancer. Versions prior to 2.9.6 are subject to a potential vulnerability in Traefik displaying the Authorization header in its debug logs. In certain cases, if the log level is set to DEBUG, credentials provided using the Authorization header are displayed in the debug logs. Attackers must have access to a users logging system in order for credentials to be stolen. This issue has been addressed in version 2.9.6. Users are advised to upgrade. Users unable to upgrade may set the log level to `INFO`, `WARN`, or `ERROR`.

Weakness: CWE-532 (Insertion of Sensitive Information into Log File), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2022-23469?

4 open source packages ship an affected version, including github.com/traefik/traefik/v2 and github.com/traefik/traefik. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/traefik/traefik/v2` | Go | All versions | 2.9.6 |
| `github.com/traefik/traefik/v2` | Go | All versions | 2.9.6 |
| `github.com/traefik/traefik/v2` | Go | All versions | 2.9.6 |
| `github.com/traefik/traefik` | Go | All versions | None |

Products: Traefik Traefik.

## How do I fix CVE-2022-23469?

Upgrade github.com/traefik/traefik/v2 to 2.9.6 or later.

## Is CVE-2022-23469 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-23469 exists.

## Other vulnerabilities in Traefik Traefik

- [CVE-2024-45410](https://insights.sbomify.com/CVE-2024-45410/): HTTP client can remove the X-Forwarded headers in Traefik (critical 9.8)
- [CVE-2026-88877](https://insights.sbomify.com/CVE-2026-88877/): Traefik v3.7.0 Authentication Bypass via from-to-www-redirect (critical 9.3)
- [CVE-2026-85595](https://insights.sbomify.com/CVE-2026-85595/): Traefik before v2.11.55 and v3.0.0 through v3.7.10 Authentication Bypass via digestAuth (critical 9.3)
- [CVE-2026-88007](https://insights.sbomify.com/CVE-2026-88007/): Traefik HTTP/3 Backend NTLM Connection Reuse (critical 9.1)
- [CVE-2026-88009](https://insights.sbomify.com/CVE-2026-88009/): Traefik: Rootless HTTP/1 request-target routes as "/" but is forwarded verbatim, bypassing path-scoped routing, middleware guards and access logging (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-23469 and fix it if it is affected.

What it is: CVE-2022-23469 is a low-severity vulnerability in Traefik Traefik, published on 8 Dec 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-23469 exists.

Affected packages and fixed versions:
- github.com/traefik/traefik/v2 (Go): affected all versions; fixed in 2.9.6
- github.com/traefik/traefik/v2 (Go): affected all versions; fixed in 2.9.6
- github.com/traefik/traefik/v2 (Go): affected all versions; fixed in 2.9.6
- github.com/traefik/traefik (Go): affected all versions; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-23469/ (Markdown: https://insights.sbomify.com/CVE-2022-23469/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-23469
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-23469
- OSV: https://osv.dev/vulnerability/CVE-2022-23469

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-23469/
Summaries are generated and may contain mistakes; the official description above is the record.
