{"answers":{"affected":"3 open source packages ship an affected version, including passeo. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-23472 in the wild and no public exploit code.","fix":"Upgrade passeo to 1.0.5 or later.","what":"CVE-2022-23472 is a medium-severity vulnerability in ArjunSharda Passeo, published on 6 Dec 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-23472 and fix it if it is affected.\n\nWhat it is: CVE-2022-23472 is a medium-severity vulnerability in ArjunSharda Passeo, published on 6 Dec 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-23472 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- passeo (PyPI): affected all versions; fixed in 1.0.5\n- passeo (PyPI): affected all versions; fixed in 1.0.5\n- passeo (PyPI): affected all versions; fixed in 1.0.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-23472/ (Markdown: https://insights.sbomify.com/CVE-2022-23472/index.md)","id":"CVE-2022-23472","markdown":"https://insights.sbomify.com/CVE-2022-23472/index.md","name":"CVE-2022-23472","record":{"aliases":["GHSA-mhhf-vgwh-fw9h","PYSEC-2022-42997"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Python password generator","requires_auth":"none","summary":"An attacker can guess generated passwords because the library uses a non-cryptographically secure random number generator.","user_interaction":"not_required","vuln_class":"weak_cryptography"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"passeo","vendor":"passeo_project"}],"cvss":{"score":5.9,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-338","name":"Use of Cryptographically Weak Pseudo-Random Number Generator (PRNG)"}],"description":"Passeo is an open source python password generator. Versions prior to 1.0.5 rely on the python `random` library for random value selection. The python `random` library warns that it should not be used for security purposes due to its reliance on a non-cryptographically secure random number generator. As a result a motivated attacker may be able to guess generated passwords. This issue has been addressed in version 1.0.5. Users are advised to upgrade. There are no known workarounds for this vulnerability.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Use of insecure random number generator in Passeo","id":"CVE-2022-23472","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"weak_cryptography","year":"2022"},"n_packages":3,"n_references":3,"next":{"headline":"Tuleap MediaWiki standalone \"readers\" can also edit pages","id":"CVE-2022-23473"},"packages":[{"ecosystem":"PyPI","fixed":["1.0.5"],"introduced":["0"],"last_affected":[],"package":"passeo","purl":null,"source":"GHSA-mhhf-vgwh-fw9h"},{"ecosystem":"PyPI","fixed":["1.0.5"],"introduced":["0"],"last_affected":[],"package":"passeo","purl":"pkg:pypi/passeo","source":"GHSA-mhhf-vgwh-fw9h"},{"ecosystem":"PyPI","fixed":["1.0.5"],"introduced":["0"],"last_affected":[],"package":"passeo","purl":"pkg:pypi/passeo","source":"PYSEC-2022-42997"}],"prev":{"headline":"containerd CRI stream server: Host memory exhaustion through terminal resize goroutine leak","id":"CVE-2022-23471"},"products":["Passeo"],"published":"2022-12-06","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-23","vendors":["ArjunSharda"]},"summary":"An attacker can guess generated passwords because the library uses a non-cryptographically secure random number generator.","url":"https://insights.sbomify.com/CVE-2022-23472/"}