# CVE-2022-23472: Use of insecure random number generator in Passeo

> An attacker can guess generated passwords because the library uses a non-cryptographically secure random number generator.

- **Severity:** Medium 5.9 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Dec 2022
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-mhhf-vgwh-fw9h, PYSEC-2022-42997

## What is CVE-2022-23472?

CVE-2022-23472 is a medium-severity vulnerability in ArjunSharda Passeo, published on 6 Dec 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Passeo is an open source python password generator. Versions prior to 1.0.5 rely on the python `random` library for random value selection. The python `random` library warns that it should not be used for security purposes due to its reliance on a non-cryptographically secure random number generator. As a result a motivated attacker may be able to guess generated passwords. This issue has been addressed in version 1.0.5. Users are advised to upgrade. There are no known workarounds for this vulnerability.

Weakness: CWE-338 (Use of Cryptographically Weak Pseudo-Random Number Generator (PRNG))

## Which versions are affected by CVE-2022-23472?

3 open source packages ship an affected version, including passeo. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `passeo` | PyPI | All versions | 1.0.5 |
| `passeo` | PyPI | All versions | 1.0.5 |
| `passeo` | PyPI | All versions | 1.0.5 |

Products: Passeo Project Passeo.

## How do I fix CVE-2022-23472?

Upgrade passeo to 1.0.5 or later.

## Is CVE-2022-23472 being exploited?

There is no known exploitation of CVE-2022-23472 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-23472 and fix it if it is affected.

What it is: CVE-2022-23472 is a medium-severity vulnerability in ArjunSharda Passeo, published on 6 Dec 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-23472 in the wild and no public exploit code.

Affected packages and fixed versions:
- passeo (PyPI): affected all versions; fixed in 1.0.5
- passeo (PyPI): affected all versions; fixed in 1.0.5
- passeo (PyPI): affected all versions; fixed in 1.0.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-23472/ (Markdown: https://insights.sbomify.com/CVE-2022-23472/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-23472
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-23472
- OSV: https://osv.dev/vulnerability/CVE-2022-23472

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-23472/
Summaries are generated and may contain mistakes; the official description above is the record.
