{"answers":{"affected":"2 open source packages ship an affected version, including @editorjs/editorjs. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-23474 exists.","fix":"Upgrade @editorjs/editorjs to 2.26.0 or later.","what":"CVE-2022-23474 is a medium-severity code injection vulnerability in codex-team editor.js, published on 15 Dec 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2022-23474 and fix it if it is affected.\n\nWhat it is: CVE-2022-23474 is a medium-severity code injection vulnerability in codex-team editor.js, published on 15 Dec 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-23474 exists.\n\nAffected packages and fixed versions:\n- @editorjs/editorjs (npm): affected all versions; fixed in 2.26.0\n- @editorjs/editorjs (npm): affected all versions; fixed in 2.26.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-23474/ (Markdown: https://insights.sbomify.com/CVE-2022-23474/index.md)","id":"CVE-2022-23474","markdown":"https://insights.sbomify.com/CVE-2022-23474/index.md","name":"CVE-2022-23474","record":{"aliases":["GHSA-6mvj-2569-3mcm"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"JavaScript editor library","requires_auth":"none","summary":"An attacker can execute arbitrary code by pasting malicious input into the Editor.js block-style editor, affecting applications using this library.","user_interaction":"required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"editor.js","vendor":"codex"}],"cvss":{"score":6.1,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"},{"id":"CWE-94","name":"Improper Control of Generation of Code"}],"description":"Editor.js is a block-style editor with clean JSON output. Versions prior to 2.26.0 are vulnerable to Code Injection via pasted input. The processHTML method passes pasted input into wrapper’s innerHTML. This issue is patched in version 2.26.0.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"editor.js contains Code Injection","id":"CVE-2022-23474","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"code_injection","year":"2022"},"n_packages":2,"n_references":2,"next":{"headline":"dalorRadius full account take over","id":"CVE-2022-23475"},"packages":[{"ecosystem":"npm","fixed":["2.26.0"],"introduced":["0"],"last_affected":[],"package":"@editorjs/editorjs","purl":null,"source":"GHSA-6mvj-2569-3mcm"},{"ecosystem":"npm","fixed":["2.26.0"],"introduced":["0"],"last_affected":[],"package":"@editorjs/editorjs","purl":"pkg:npm/%40editorjs/editorjs","source":"GHSA-6mvj-2569-3mcm"}],"prev":{"headline":"Tuleap MediaWiki standalone \"readers\" can also edit pages","id":"CVE-2022-23473"},"products":["editor.js"],"published":"2022-12-15","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-17","vendors":["codex-team"]},"summary":"An attacker can execute arbitrary code by pasting malicious input into the Editor.js block-style editor, affecting applications using this library.","url":"https://insights.sbomify.com/CVE-2022-23474/"}