# CVE-2022-23474: editor.js contains Code Injection

> An attacker can execute arbitrary code by pasting malicious input into the Editor.js block-style editor, affecting applications using this library.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 15 Dec 2022
- **Updated:** 17 Apr 2025
- **Also known as:** GHSA-6mvj-2569-3mcm

## What is CVE-2022-23474?

CVE-2022-23474 is a medium-severity code injection vulnerability in codex-team editor.js, published on 15 Dec 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Editor.js is a block-style editor with clean JSON output. Versions prior to 2.26.0 are vulnerable to Code Injection via pasted input. The processHTML method passes pasted input into wrapper’s innerHTML. This issue is patched in version 2.26.0.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation), CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2022-23474?

2 open source packages ship an affected version, including @editorjs/editorjs. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@editorjs/editorjs` | npm | All versions | 2.26.0 |
| `@editorjs/editorjs` | npm | All versions | 2.26.0 |

Products: Codex Editor.js.

## How do I fix CVE-2022-23474?

Upgrade @editorjs/editorjs to 2.26.0 or later.

## Is CVE-2022-23474 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-23474 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-23474 and fix it if it is affected.

What it is: CVE-2022-23474 is a medium-severity code injection vulnerability in codex-team editor.js, published on 15 Dec 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-23474 exists.

Affected packages and fixed versions:
- @editorjs/editorjs (npm): affected all versions; fixed in 2.26.0
- @editorjs/editorjs (npm): affected all versions; fixed in 2.26.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-23474/ (Markdown: https://insights.sbomify.com/CVE-2022-23474/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-23474
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-23474
- OSV: https://osv.dev/vulnerability/CVE-2022-23474

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-23474/
Summaries are generated and may contain mistakes; the official description above is the record.
