{"answers":{"affected":"2 open source packages ship an affected version, including nokogiri. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-23476 in the wild and no public exploit code.","fix":"Upgrade nokogiri to 1.13.10 or later.","what":"CVE-2022-23476 is a high-severity vulnerability in sparklemotion nokogiri, published on 8 Dec 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-23476 and fix it if it is affected.\n\nWhat it is: CVE-2022-23476 is a high-severity vulnerability in sparklemotion nokogiri, published on 8 Dec 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-23476 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- nokogiri (RubyGems): affected from 1.13.8; fixed in 1.13.10\n- nokogiri (RubyGems): affected from 1.13.8; fixed in 1.13.10\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-23476/ (Markdown: https://insights.sbomify.com/CVE-2022-23476/index.md)","id":"CVE-2022-23476","markdown":"https://insights.sbomify.com/CVE-2022-23476/index.md","name":"CVE-2022-23476","record":{"aliases":["DEBIAN-CVE-2022-23476","GHSA-qv4q-mr5r-qprj"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Ruby XML library","requires_auth":"none","summary":"Attackers can cause a denial of service via null pointer exception in Nokogiri when parsing invalid markup with XML::Reader.","user_interaction":"not_required","vuln_class":"null_dereference"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"nokogiri","vendor":"nokogiri"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-476","name":"NULL Pointer Dereference"},{"id":"CWE-252","name":"Unchecked Return Value"}],"description":"Nokogiri is an open source XML and HTML library for the Ruby programming language. Nokogiri `1.13.8` and `1.13.9` fail to check the return value from `xmlTextReaderExpand` in the method `Nokogiri::XML::Reader#attribute_hash`. This can lead to a null pointer exception when invalid markup is being parsed. For applications using `XML::Reader` to parse untrusted inputs, this may potentially be a vector for a denial of service attack. Users are advised to upgrade to Nokogiri `\u003e= 1.13.10`. Users may be able to search their code for calls to either `XML::Reader#attributes` or `XML::Reader#attribute_hash` to determine if they are affected.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Unchecked return value from xmlTextReaderExpand in Nokogiri","id":"CVE-2022-23476","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"null_dereference","year":"2022"},"n_packages":2,"n_references":3,"next":{"headline":"Buffer Overflow in xrdp","id":"CVE-2022-23477"},"packages":[{"ecosystem":"RubyGems","fixed":["1.13.10"],"introduced":["1.13.8"],"last_affected":[],"package":"nokogiri","purl":null,"source":"GHSA-qv4q-mr5r-qprj"},{"ecosystem":"RubyGems","fixed":["1.13.10"],"introduced":["1.13.8"],"last_affected":[],"package":"nokogiri","purl":"pkg:gem/nokogiri","source":"GHSA-qv4q-mr5r-qprj"}],"prev":{"headline":"dalorRadius full account take over","id":"CVE-2022-23475"},"products":["nokogiri"],"published":"2022-12-08","related":[{"cvss_score":8.7,"headline":"Nokogiri before 1.19.3 ReDoS via CSS selector tokenizer","id":"CVE-2026-79770","kev_date_added":null,"published":"2026-08-25"},{"cvss_score":7.5,"headline":"Improper Restriction of XML External Entity Reference (XXE) in Nokogiri on JRuby","id":"CVE-2021-41098","kev_date_added":null,"published":"2021-09-27"},{"cvss_score":7.5,"headline":"Nokogiri is vulnerable to XML External Entity (XXE) attack","id":"CVE-2012-6685","kev_date_added":null,"published":"2020-02-19"},{"cvss_score":6.9,"headline":"Nokogiri before 1.19.3 Memory Leak via XSLT Transform","id":"CVE-2026-79771","kev_date_added":null,"published":"2026-08-25"},{"cvss_score":6.9,"headline":"Nokogiri before 1.19.1 Unchecked Return Value canonicalize","id":"CVE-2026-79772","kev_date_added":null,"published":"2026-08-25"},{"cvss_score":6.3,"headline":"Nokogiri: Possible Out-of-Bounds Read in `Nokogiri::XML::NodeSet#[]`","id":"CVE-2026-57235","kev_date_added":null,"published":"2026-06-25"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-23","vendors":["sparklemotion"]},"summary":"Attackers can cause a denial of service via null pointer exception in Nokogiri when parsing invalid markup with XML::Reader.","url":"https://insights.sbomify.com/CVE-2022-23476/"}