CVE-2022-23485 Invite code reuse via cookie manipulation in sentry
Attackers can reuse invite links via cookie manipulation to create multiple accounts and join organizations without authorization.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2022-23485?
CVE-2022-23485 is a medium-severity vulnerability in getsentry sentry, published on 10 Dec 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Sentry is an error tracking and performance monitoring platform. In versions of the sentry python library prior to 22.11.0 an attacker with a known valid invite link could manipulate a cookie to allow the same invite link to be reused on multiple accounts when joining an organization. As a result an attacker with a valid invite link can create multiple users and join an organization they may not have been originally invited to. This issue was patched in version 22.11.0. Sentry SaaS customers do not need to take action. Self-hosted Sentry installs on systems which can not upgrade can disable the invite functionality until they are ready to deploy the patched version by editing their `sentry.conf.py` file (usually located at `~/.sentry/`).
Which versions are affected by CVE-2022-23485?
3 open source packages ship an affected version, including sentry. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
sentry PyPI | From 20.6.0 | 22.11.0 |
sentry PyPI | From 20.6.0 | 22.11.0 |
sentry PyPI | From 20.6.0 | 22.11.0 |
Products include Sentry Sentry.
How do I fix CVE-2022-23485?
Upgrade sentry to 22.11.0 or later.
Is CVE-2022-23485 being exploited?
There is no known exploitation of CVE-2022-23485 in the wild and no public exploit code.
Other vulnerabilities in getsentry sentry
- CVE-2026-42354 Sentry: Improper authentication on SAML SSO process allows user identity linking
- CVE-2026-27197 Sentry: Improper Authentication on SAML SSO process allows user identity linking
- CVE-2021-47935 Sentry 8.2.0 Remote Code Execution via Pickle Deserialization
- CVE-2023-39349 Sentry vulnerable to privilege escalation via ApiTokensEndpoint
- CVE-2023-36826 Sentry vulnerable to improper authorization on debug and artifact file downloads
Sources
Also known as GHSA-jv85-mqxj-3f9j, PYSEC-2022-43011, UBUNTU-CVE-2022-23485.