{"answers":{"affected":"3 open source packages ship an affected version, including sentry. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-23485 in the wild and no public exploit code.","fix":"Upgrade sentry to 22.11.0 or later.","what":"CVE-2022-23485 is a medium-severity vulnerability in getsentry sentry, published on 10 Dec 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2022-23485 and fix it if it is affected.\n\nWhat it is: CVE-2022-23485 is a medium-severity vulnerability in getsentry sentry, published on 10 Dec 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2022-23485 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- sentry (PyPI): affected from 20.6.0; fixed in 22.11.0\n- sentry (PyPI): affected from 20.6.0; fixed in 22.11.0\n- sentry (PyPI): affected from 20.6.0; fixed in 22.11.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-23485/ (Markdown: https://insights.sbomify.com/CVE-2022-23485/index.md)","id":"CVE-2022-23485","markdown":"https://insights.sbomify.com/CVE-2022-23485/index.md","name":"CVE-2022-23485","record":{"aliases":["GHSA-jv85-mqxj-3f9j","PYSEC-2022-43011","UBUNTU-CVE-2022-23485"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["privilege_escalation","data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Sentry error tracking","requires_auth":"none","summary":"Attackers can reuse invite links via cookie manipulation to create multiple accounts and join organizations without authorization.","user_interaction":"required","vuln_class":"business_logic"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"sentry","vendor":"sentry"}],"cvss":{"score":6.4,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-284","name":"Improper Access Control"},{"id":"CWE-269","name":"Improper Privilege Management"}],"description":"Sentry is an error tracking and performance monitoring platform. In versions of the sentry python library prior to 22.11.0 an attacker with a known valid invite link could manipulate a cookie to allow the same invite link to be reused on multiple accounts when joining an organization. As a result an attacker with a valid invite link can create multiple users and join an organization they may not have been originally invited to. This issue was patched in version 22.11.0. Sentry SaaS customers do not need to take action. Self-hosted Sentry installs on systems which can not upgrade can disable the invite functionality until they are ready to deploy the patched version by editing their `sentry.conf.py` file (usually located at `~/.sentry/`).","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Invite code reuse via cookie manipulation in sentry","id":"CVE-2022-23485","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"business_logic","year":"2022"},"n_packages":3,"n_references":1,"next":{"headline":"libp2p-rust denial of service vulnerability from lack of resource management","id":"CVE-2022-23486"},"packages":[{"ecosystem":"PyPI","fixed":["22.11.0"],"introduced":["20.6.0"],"last_affected":[],"package":"sentry","purl":null,"source":"GHSA-jv85-mqxj-3f9j"},{"ecosystem":"PyPI","fixed":["22.11.0"],"introduced":["20.6.0"],"last_affected":[],"package":"sentry","purl":"pkg:pypi/sentry","source":"GHSA-jv85-mqxj-3f9j"},{"ecosystem":"PyPI","fixed":["22.11.0"],"introduced":["20.6.0"],"last_affected":[],"package":"sentry","purl":"pkg:pypi/sentry","source":"PYSEC-2022-43011"}],"prev":{"headline":"Integer Overflow in xrdp","id":"CVE-2022-23484"},"products":["sentry"],"published":"2022-12-10","related":[{"cvss_score":9.1,"headline":"Sentry: Improper authentication on SAML SSO process allows user identity linking","id":"CVE-2026-42354","kev_date_added":null,"published":"2026-05-08"},{"cvss_score":9.1,"headline":"Sentry: Improper Authentication on SAML SSO process allows user identity linking","id":"CVE-2026-27197","kev_date_added":null,"published":"2026-02-21"},{"cvss_score":8.7,"headline":"Sentry 8.2.0 Remote Code Execution via Pickle Deserialization","id":"CVE-2021-47935","kev_date_added":null,"published":"2026-05-10"},{"cvss_score":8.1,"headline":"Sentry vulnerable to privilege escalation via ApiTokensEndpoint","id":"CVE-2023-39349","kev_date_added":null,"published":"2023-08-07"},{"cvss_score":7.7,"headline":"Sentry vulnerable to improper authorization on debug and artifact file downloads","id":"CVE-2023-36826","kev_date_added":null,"published":"2023-07-25"},{"cvss_score":7.5,"headline":"Sentry: Inefficient Regular Expression Complexity in sentry","id":"CVE-2026-52794","kev_date_added":null,"published":"2026-06-24"},{"cvss_score":7.3,"headline":"Sentry's superuser cleartext password leaked in logs","id":"CVE-2024-32474","kev_date_added":null,"published":"2024-04-18"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-23","vendors":["getsentry"]},"summary":"Attackers can reuse invite links via cookie manipulation to create multiple accounts and join organizations without authorization.","url":"https://insights.sbomify.com/CVE-2022-23485/"}