# CVE-2022-23485: Invite code reuse via cookie manipulation in sentry

> Attackers can reuse invite links via cookie manipulation to create multiple accounts and join organizations without authorization.

- **Severity:** Medium 6.4 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 10 Dec 2022
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-jv85-mqxj-3f9j, PYSEC-2022-43011, UBUNTU-CVE-2022-23485

## What is CVE-2022-23485?

CVE-2022-23485 is a medium-severity vulnerability in getsentry sentry, published on 10 Dec 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Sentry is an error tracking and performance monitoring platform. In versions of the sentry python library prior to 22.11.0 an attacker with a known valid invite link could manipulate a cookie to allow the same invite link to be reused on multiple accounts when joining an organization. As a result an attacker with a valid invite link can create multiple users and join an organization they may not have been originally invited to. This issue was patched in version 22.11.0. Sentry SaaS customers do not need to take action. Self-hosted Sentry installs on systems which can not upgrade can disable the invite functionality until they are ready to deploy the patched version by editing their `sentry.conf.py` file (usually located at `~/.sentry/`).

Weakness: CWE-284 (Improper Access Control), CWE-269 (Improper Privilege Management)

## Which versions are affected by CVE-2022-23485?

3 open source packages ship an affected version, including sentry. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `sentry` | PyPI | From 20.6.0 | 22.11.0 |
| `sentry` | PyPI | From 20.6.0 | 22.11.0 |
| `sentry` | PyPI | From 20.6.0 | 22.11.0 |

Products: Sentry Sentry.

## How do I fix CVE-2022-23485?

Upgrade sentry to 22.11.0 or later.

## Is CVE-2022-23485 being exploited?

There is no known exploitation of CVE-2022-23485 in the wild and no public exploit code.

## Other vulnerabilities in getsentry sentry

- [CVE-2026-42354](https://insights.sbomify.com/CVE-2026-42354/): Sentry: Improper authentication on SAML SSO process allows user identity linking (critical 9.1)
- [CVE-2026-27197](https://insights.sbomify.com/CVE-2026-27197/): Sentry: Improper Authentication on SAML SSO process allows user identity linking (critical 9.1)
- [CVE-2021-47935](https://insights.sbomify.com/CVE-2021-47935/): Sentry 8.2.0 Remote Code Execution via Pickle Deserialization (high 8.7)
- [CVE-2023-39349](https://insights.sbomify.com/CVE-2023-39349/): Sentry vulnerable to privilege escalation via ApiTokensEndpoint (high 8.1)
- [CVE-2023-36826](https://insights.sbomify.com/CVE-2023-36826/): Sentry vulnerable to improper authorization on debug and artifact file downloads (high 7.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-23485 and fix it if it is affected.

What it is: CVE-2022-23485 is a medium-severity vulnerability in getsentry sentry, published on 10 Dec 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-23485 in the wild and no public exploit code.

Affected packages and fixed versions:
- sentry (PyPI): affected from 20.6.0; fixed in 22.11.0
- sentry (PyPI): affected from 20.6.0; fixed in 22.11.0
- sentry (PyPI): affected from 20.6.0; fixed in 22.11.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-23485/ (Markdown: https://insights.sbomify.com/CVE-2022-23485/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-23485
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-23485
- OSV: https://osv.dev/vulnerability/CVE-2022-23485

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-23485/
Summaries are generated and may contain mistakes; the official description above is the record.
