# CVE-2022-23486: libp2p-rust denial of service vulnerability from lack of resource management

> An attacker can exhaust memory resources in libp2p nodes, causing a denial of service by forcing the process to crash.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Dec 2022
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-jvgw-gccv-q5p8, RUSTSEC-2022-0084

## What is CVE-2022-23486?

CVE-2022-23486 is a high-severity denial of service vulnerability in rust-libp2p, published on 7 Dec 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

libp2p-rust is the official rust language Implementation of the libp2p networking stack. In versions prior to 0.45.1 an attacker node can cause a victim node to allocate a large number of small memory chunks, which can ultimately lead to the victim’s process running out of memory and thus getting killed by its operating system. When executed continuously, this can lead to a denial of service attack, especially relevant on a larger scale when run against more than one node of a libp2p based network. Users are advised to upgrade to `libp2p` `v0.45.1` or above. Users unable to upgrade should reference the DoS Mitigation page for more information on how to incorporate mitigation strategies, monitor their application, and respond to attacks: https://docs.libp2p.io/reference/dos-mitigation/.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling), CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2022-23486?

3 open source packages ship an affected version, including libp2p. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `libp2p` | crates.io | All versions | 0.45.1 |
| `libp2p` | crates.io | All versions | 0.45.1 |
| `libp2p` | crates.io | From 0.0.0-0 | 0.45.1 |

Products: Protocol Libp2p.

## How do I fix CVE-2022-23486?

Upgrade libp2p to 0.45.1 or later.

## Is CVE-2022-23486 being exploited?

There is no known exploitation of CVE-2022-23486 in the wild and no public exploit code.

## Other vulnerabilities in rust-libp2p

- [CVE-2026-35457](https://insights.sbomify.com/CVE-2026-35457/): libp2p-rust has unbounded rendezvous DISCOVER cookies enable remote memory exhaustion (high 8.2)
- [CVE-2026-35405](https://insights.sbomify.com/CVE-2026-35405/): libp2p-rendezvous: Unlimited namespace registrations per peer enables OOM DoS on rendezvous servers (high 7.5)
- [CVE-2023-40583](https://insights.sbomify.com/CVE-2023-40583/): libp2p nodes vulnerable to OOM attack (high 7.5)
- [CVE-2022-23492](https://insights.sbomify.com/CVE-2022-23492/): go-libp2p denial of service vulnerability from lack of resource management (high 7.5)
- [CVE-2022-23487](https://insights.sbomify.com/CVE-2022-23487/): libp2p denial of service vulnerability from lack of resource management (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-23486 and fix it if it is affected.

What it is: CVE-2022-23486 is a high-severity denial of service vulnerability in rust-libp2p, published on 7 Dec 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-23486 in the wild and no public exploit code.

Affected packages and fixed versions:
- libp2p (crates.io): affected all versions; fixed in 0.45.1
- libp2p (crates.io): affected all versions; fixed in 0.45.1
- libp2p (crates.io): affected from 0.0.0-0; fixed in 0.45.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-23486/ (Markdown: https://insights.sbomify.com/CVE-2022-23486/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-23486
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-23486
- OSV: https://osv.dev/vulnerability/CVE-2022-23486

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-23486/
Summaries are generated and may contain mistakes; the official description above is the record.
