{"answers":{"affected":"2 open source packages ship an affected version, including libp2p. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-23487 in the wild and no public exploit code.","fix":"Upgrade libp2p to 0.38.0 or later.","what":"CVE-2022-23487 is a high-severity denial of service vulnerability in js-libp2p, published on 7 Dec 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-23487 and fix it if it is affected.\n\nWhat it is: CVE-2022-23487 is a high-severity denial of service vulnerability in js-libp2p, published on 7 Dec 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-23487 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- libp2p (npm): affected all versions; fixed in 0.38.0\n- libp2p (npm): affected all versions; fixed in 0.38.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-23487/ (Markdown: https://insights.sbomify.com/CVE-2022-23487/index.md)","id":"CVE-2022-23487","markdown":"https://insights.sbomify.com/CVE-2022-23487/index.md","name":"CVE-2022-23487","record":{"aliases":["CLSA-2026-1790600625","CLSA-2026-1792198239","GHSA-f44q-634c-jvwv"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"JavaScript networking library","requires_auth":"none","summary":"An attacker can exhaust resources in js-libp2p, causing the process to crash via memory exhaustion.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"libp2p","vendor":"protocol"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-770","name":"Allocation of Resources Without Limits or Throttling"},{"id":"CWE-400","name":"Uncontrolled Resource Consumption"}],"description":"js-libp2p is the official javascript Implementation of libp2p networking stack. Versions older than `v0.38.0` of js-libp2p are vulnerable to targeted resource exhaustion attacks. These attacks target libp2p’s connection, stream, peer, and memory management. An attacker can cause the allocation of large amounts of memory, ultimately leading to the process getting killed by the host’s operating system. While a connection manager tasked with keeping the number of connections within manageable limits has been part of js-libp2p, this component was designed to handle the regular churn of peers, not a targeted resource exhaustion attack. Users are advised to update their js-libp2p dependency to `v0.38.0` or greater. There are no known workarounds for this vulnerability.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"libp2p denial of service vulnerability from lack of resource management","id":"CVE-2022-23487","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2022"},"n_packages":2,"n_references":1,"next":{"headline":"BigBlueButton vulnerable to Insertion of Sensitive Information Into Sent Data","id":"CVE-2022-23488"},"packages":[{"ecosystem":"npm","fixed":["0.38.0"],"introduced":["0"],"last_affected":[],"package":"libp2p","purl":null,"source":"GHSA-f44q-634c-jvwv"},{"ecosystem":"npm","fixed":["0.38.0"],"introduced":["0"],"last_affected":[],"package":"libp2p","purl":"pkg:npm/libp2p","source":"GHSA-f44q-634c-jvwv"}],"prev":{"headline":"libp2p-rust denial of service vulnerability from lack of resource management","id":"CVE-2022-23486"},"products":["js-libp2p"],"published":"2022-12-07","related":[{"cvss_score":8.2,"headline":"libp2p-rust has unbounded rendezvous DISCOVER cookies enable remote memory exhaustion","id":"CVE-2026-35457","kev_date_added":null,"published":"2026-04-07"},{"cvss_score":7.5,"headline":"libp2p-rendezvous: Unlimited namespace registrations per peer enables OOM DoS on rendezvous servers","id":"CVE-2026-35405","kev_date_added":null,"published":"2026-04-07"},{"cvss_score":7.5,"headline":"libp2p nodes vulnerable to OOM attack","id":"CVE-2023-40583","kev_date_added":null,"published":"2023-08-25"},{"cvss_score":7.5,"headline":"go-libp2p denial of service vulnerability from lack of resource management","id":"CVE-2022-23492","kev_date_added":null,"published":"2022-12-08"},{"cvss_score":7.5,"headline":"libp2p-rust denial of service vulnerability from lack of resource management","id":"CVE-2022-23486","kev_date_added":null,"published":"2022-12-07"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-23","vendors":["libp2p"]},"summary":"An attacker can exhaust resources in js-libp2p, causing the process to crash via memory exhaustion.","url":"https://insights.sbomify.com/CVE-2022-23487/"}