# CVE-2022-23487: libp2p denial of service vulnerability from lack of resource management

> An attacker can exhaust resources in js-libp2p, causing the process to crash via memory exhaustion.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Dec 2022
- **Updated:** 23 Apr 2025
- **Also known as:** CLSA-2026-1790600625, CLSA-2026-1792198239, GHSA-f44q-634c-jvwv

## What is CVE-2022-23487?

CVE-2022-23487 is a high-severity denial of service vulnerability in js-libp2p, published on 7 Dec 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

js-libp2p is the official javascript Implementation of libp2p networking stack. Versions older than `v0.38.0` of js-libp2p are vulnerable to targeted resource exhaustion attacks. These attacks target libp2p’s connection, stream, peer, and memory management. An attacker can cause the allocation of large amounts of memory, ultimately leading to the process getting killed by the host’s operating system. While a connection manager tasked with keeping the number of connections within manageable limits has been part of js-libp2p, this component was designed to handle the regular churn of peers, not a targeted resource exhaustion attack. Users are advised to update their js-libp2p dependency to `v0.38.0` or greater. There are no known workarounds for this vulnerability.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling), CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2022-23487?

2 open source packages ship an affected version, including libp2p. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `libp2p` | npm | All versions | 0.38.0 |
| `libp2p` | npm | All versions | 0.38.0 |

Products: Protocol Libp2p.

## How do I fix CVE-2022-23487?

Upgrade libp2p to 0.38.0 or later.

## Is CVE-2022-23487 being exploited?

There is no known exploitation of CVE-2022-23487 in the wild and no public exploit code.

## Other vulnerabilities in js-libp2p

- [CVE-2026-35457](https://insights.sbomify.com/CVE-2026-35457/): libp2p-rust has unbounded rendezvous DISCOVER cookies enable remote memory exhaustion (high 8.2)
- [CVE-2026-35405](https://insights.sbomify.com/CVE-2026-35405/): libp2p-rendezvous: Unlimited namespace registrations per peer enables OOM DoS on rendezvous servers (high 7.5)
- [CVE-2023-40583](https://insights.sbomify.com/CVE-2023-40583/): libp2p nodes vulnerable to OOM attack (high 7.5)
- [CVE-2022-23492](https://insights.sbomify.com/CVE-2022-23492/): go-libp2p denial of service vulnerability from lack of resource management (high 7.5)
- [CVE-2022-23486](https://insights.sbomify.com/CVE-2022-23486/): libp2p-rust denial of service vulnerability from lack of resource management (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-23487 and fix it if it is affected.

What it is: CVE-2022-23487 is a high-severity denial of service vulnerability in js-libp2p, published on 7 Dec 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-23487 in the wild and no public exploit code.

Affected packages and fixed versions:
- libp2p (npm): affected all versions; fixed in 0.38.0
- libp2p (npm): affected all versions; fixed in 0.38.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-23487/ (Markdown: https://insights.sbomify.com/CVE-2022-23487/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-23487
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-23487
- OSV: https://osv.dev/vulnerability/CVE-2022-23487

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-23487/
Summaries are generated and may contain mistakes; the official description above is the record.
