CVE-2022-23492 go-libp2p denial of service vulnerability from lack of resource management

High 7.5 Published Updated

An attacker can exhaust resources in go-libp2p, causing the application to crash due to memory exhaustion.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2022-23492?

CVE-2022-23492 is a high-severity denial of service vulnerability in go-libp2p, published on 8 Dec 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

go-libp2p is the offical libp2p implementation in the Go programming language. Version `0.18.0` and older of go-libp2p are vulnerable to targeted resource exhaustion attacks. These attacks target libp2p’s connection, stream, peer, and memory management. An attacker can cause the allocation of large amounts of memory, ultimately leading to the process getting killed by the host’s operating system. While a connection manager tasked with keeping the number of connections within manageable limits has been part of go-libp2p, this component was designed to handle the regular churn of peers, not a targeted resource exhaustion attack. Users are advised to upgrade their version of go-libp2p to version `0.18.1` or newer. Users unable to upgrade may consult the denial of service (dos) mitigation page for more information on how to incorporate mitigation strategies, monitor your application, and respond to attacks.

Weakness: CWE-770, CWE-400

Which versions are affected by CVE-2022-23492?

3 open source packages ship an affected version, including github.com/libp2p/go-libp2p. It affects 1 product.

PackageAffectedFixed in
github.com/libp2p/go-libp2p GoAll versions0.18.0
github.com/libp2p/go-libp2p GoAll versions0.18.0
github.com/libp2p/go-libp2p GoAll versions0.18.0

Products include Protocol Libp2p.

How do I fix CVE-2022-23492?

Upgrade github.com/libp2p/go-libp2p to 0.18.0 or later.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2022-23492 being exploited?

There is no known exploitation of CVE-2022-23492 in the wild and no public exploit code.

Sources

Also known as GHSA-j7qp-mfxf-8xjw, GO-2022-1148.

Is CVE-2022-23492 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free