# CVE-2022-23494: Cross-site scripting vulnerability in TinyMCE alerts

> Attackers can execute arbitrary JavaScript via malicious HTML in TinyMCE alert dialogs, affecting users of plugins like image.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 8 Dec 2022
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-gg8r-xjwq-4w92, UBUNTU-CVE-2022-23494

## What is CVE-2022-23494?

CVE-2022-23494 is a medium-severity cross-site scripting vulnerability in tinymce, published on 8 Dec 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

tinymce is an open source rich text editor. A cross-site scripting (XSS) vulnerability was discovered in the alert and confirm dialogs when these dialogs were provided with malicious HTML content. This can occur in plugins that use the alert or confirm dialogs, such as in the `image` plugin, which presents these dialogs when certain errors occur. The vulnerability allowed arbitrary JavaScript execution when an alert presented in the TinyMCE UI for the current user. This vulnerability has been patched in TinyMCE 5.10.7 and TinyMCE 6.3.1 by ensuring HTML sanitization was still performed after unwrapping invalid elements. Users are advised to upgrade to either 5.10.7 or 6.3.1. Users unable to upgrade may ensure the the `images_upload_handler` returns a valid value as per the images_upload_handler documentation.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2022-23494?

12 open source packages ship an affected version, including TinyMCE, tinymce/tinymce and tinymce. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `TinyMCE` | NuGet | All versions | 5.10.7 |
| `TinyMCE` | NuGet | All versions | 5.10.7 |
| `TinyMCE` | NuGet | From 6.0.0 | 6.3.1 |
| `TinyMCE` | NuGet | From 6.0.0 | 6.3.1 |
| `tinymce/tinymce` | Packagist | All versions | 5.10.7 |
| `tinymce/tinymce` | Packagist | All versions | 5.10.7 |
| `tinymce/tinymce` | Packagist | From 6.0.0 | 6.3.1 |
| `tinymce/tinymce` | Packagist | From 6.0.0 | 6.3.1 |
| `tinymce` | npm | All versions | 5.10.7 |
| `tinymce` | npm | All versions | 5.10.7 |
| `tinymce` | npm | From 6.0.0 | 6.3.1 |
| `tinymce` | npm | From 6.0.0 | 6.3.1 |

Products: Tiny Tinymce.

## How do I fix CVE-2022-23494?

Upgrade TinyMCE to a fixed version for your release line: 5.10.7 or 6.3.1.

## Is CVE-2022-23494 being exploited?

There is no known exploitation of CVE-2022-23494 in the wild and no public exploit code.

## Other vulnerabilities in tinymce

- [CVE-2026-47759](https://insights.sbomify.com/CVE-2026-47759/): TinyMCE Cross-Site Scripting (XSS) vulnerability using through data-mce- prefixed src, href, style attributes (high 8.7)
- [CVE-2026-47760](https://insights.sbomify.com/CVE-2026-47760/): TinyMCE Cross-Site Scripting (XSS) vulnerability using sanitization bypass through nested SVGs (high 8.7)
- [CVE-2026-47761](https://insights.sbomify.com/CVE-2026-47761/): TinyMCE Cross-Site Scripting (XSS) vulnerability using media plugin `data-mce-object` injection (high 8.7)
- [CVE-2026-47762](https://insights.sbomify.com/CVE-2026-47762/): TinyMCE Cross-Site Scripting (XSS) vulnerability through `mce:protected` comments (high 8.7)
- [CVE-2024-21908](https://insights.sbomify.com/CVE-2024-21908/): Cross-site scripting vulnerability in TinyMCE (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-23494 and fix it if it is affected.

What it is: CVE-2022-23494 is a medium-severity cross-site scripting vulnerability in tinymce, published on 8 Dec 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-23494 in the wild and no public exploit code.

Affected packages and fixed versions:
- TinyMCE (NuGet): affected all versions; fixed in 5.10.7
- TinyMCE (NuGet): affected all versions; fixed in 5.10.7
- TinyMCE (NuGet): affected from 6.0.0; fixed in 6.3.1
- TinyMCE (NuGet): affected from 6.0.0; fixed in 6.3.1
- tinymce/tinymce (Packagist): affected all versions; fixed in 5.10.7
- tinymce/tinymce (Packagist): affected all versions; fixed in 5.10.7
- tinymce/tinymce (Packagist): affected from 6.0.0; fixed in 6.3.1
- tinymce/tinymce (Packagist): affected from 6.0.0; fixed in 6.3.1
- tinymce (npm): affected all versions; fixed in 5.10.7
- tinymce (npm): affected all versions; fixed in 5.10.7
- tinymce (npm): affected from 6.0.0; fixed in 6.3.1
- tinymce (npm): affected from 6.0.0; fixed in 6.3.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-23494/ (Markdown: https://insights.sbomify.com/CVE-2022-23494/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-23494
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-23494
- OSV: https://osv.dev/vulnerability/CVE-2022-23494

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-23494/
Summaries are generated and may contain mistakes; the official description above is the record.
