# CVE-2022-23496: A crafted list can trigger a ArrayIndexOutOfBoundsException in Yauaa

> A crafted list in Client Hints analysis causes an uncaught exception, crashing applications using the Yauaa Java library.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Dec 2022
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-c4pm-63cg-9j7h

## What is CVE-2022-23496?

CVE-2022-23496 is a high-severity denial of service vulnerability in nielsbasjes yauaa, published on 8 Dec 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Yet Another UserAgent Analyzer (Yauaa) is a java library that tries to parse and analyze the useragent string and extract as many relevant attributes as possible. Applications using the Client Hints analysis feature introduced with 7.0.0 can crash because the Yauaa library throws an ArrayIndexOutOfBoundsException. If uncaught the exception will result in a program crash. Applications that do not use this feature are not affected. Users are advised to upgrade to version 7.9.0. Users unable to upgrade may catch and discard any ArrayIndexOutOfBoundsException thrown by the Yauaa library.

Weakness: CWE-755 (Improper Handling of Exceptional Conditions)

## Which versions are affected by CVE-2022-23496?

24 open source packages ship an affected version, including nl.basjes.parse.useragent:yauaa, nl.basjes.parse.useragent:yauaa-beam and nl.basjes.parse.useragent:yauaa-beam-sql. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nl.basjes.parse.useragent:yauaa` | Maven | From 7.0.0 | 7.9.0 |
| `nl.basjes.parse.useragent:yauaa` | Maven | From 7.0.0 | 7.9.0 |
| `nl.basjes.parse.useragent:yauaa-beam` | Maven | From 7.0.0 | 7.9.0 |
| `nl.basjes.parse.useragent:yauaa-beam` | Maven | From 7.0.0 | 7.9.0 |
| `nl.basjes.parse.useragent:yauaa-beam-sql` | Maven | From 7.0.0 | 7.9.0 |
| `nl.basjes.parse.useragent:yauaa-beam-sql` | Maven | From 7.0.0 | 7.9.0 |
| `nl.basjes.parse.useragent:yauaa-drill` | Maven | From 7.0.0 | 7.9.0 |
| `nl.basjes.parse.useragent:yauaa-drill` | Maven | From 7.0.0 | 7.9.0 |
| `nl.basjes.parse.useragent:yauaa-elasticsearch` | Maven | From 7.0.0 | 7.9.0 |
| `nl.basjes.parse.useragent:yauaa-elasticsearch` | Maven | From 7.0.0 | 7.9.0 |
| `nl.basjes.parse.useragent:yauaa-elasticsearch-8` | Maven | From 7.0.0 | 7.9.0 |
| `nl.basjes.parse.useragent:yauaa-elasticsearch-8` | Maven | From 7.0.0 | 7.9.0 |
| `nl.basjes.parse.useragent:yauaa-flink` | Maven | From 7.0.0 | 7.9.0 |
| `nl.basjes.parse.useragent:yauaa-flink` | Maven | From 7.0.0 | 7.9.0 |
| `nl.basjes.parse.useragent:yauaa-flink-table` | Maven | From 7.0.0 | 7.9.0 |
| `nl.basjes.parse.useragent:yauaa-flink-table` | Maven | From 7.0.0 | 7.9.0 |
| `nl.basjes.parse.useragent:yauaa-hive` | Maven | From 7.0.0 | 7.9.0 |
| `nl.basjes.parse.useragent:yauaa-hive` | Maven | From 7.0.0 | 7.9.0 |
| `nl.basjes.parse.useragent:yauaa-logparser` | Maven | From 7.0.0 | 7.9.0 |
| `nl.basjes.parse.useragent:yauaa-logparser` | Maven | From 7.0.0 | 7.9.0 |
| `nl.basjes.parse.useragent:yauaa-snowflake` | Maven | From 7.0.0 | 7.9.0 |
| `nl.basjes.parse.useragent:yauaa-snowflake` | Maven | From 7.0.0 | 7.9.0 |
| `nl.basjes.parse.useragent:yauaa-trino` | Maven | From 7.0.0 | 7.9.0 |
| `nl.basjes.parse.useragent:yauaa-trino` | Maven | From 7.0.0 | 7.9.0 |

Products: Yet Another Useragent Analyzer Project Yet Another Useragent Analyzer.

## How do I fix CVE-2022-23496?

Upgrade nl.basjes.parse.useragent:yauaa to 7.9.0 or later.

## Is CVE-2022-23496 being exploited?

There is no known exploitation of CVE-2022-23496 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-23496 and fix it if it is affected.

What it is: CVE-2022-23496 is a high-severity denial of service vulnerability in nielsbasjes yauaa, published on 8 Dec 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-23496 in the wild and no public exploit code.

Affected packages and fixed versions:
- nl.basjes.parse.useragent:yauaa (Maven): affected from 7.0.0; fixed in 7.9.0
- nl.basjes.parse.useragent:yauaa (Maven): affected from 7.0.0; fixed in 7.9.0
- nl.basjes.parse.useragent:yauaa-beam (Maven): affected from 7.0.0; fixed in 7.9.0
- nl.basjes.parse.useragent:yauaa-beam (Maven): affected from 7.0.0; fixed in 7.9.0
- nl.basjes.parse.useragent:yauaa-beam-sql (Maven): affected from 7.0.0; fixed in 7.9.0
- nl.basjes.parse.useragent:yauaa-beam-sql (Maven): affected from 7.0.0; fixed in 7.9.0
- nl.basjes.parse.useragent:yauaa-drill (Maven): affected from 7.0.0; fixed in 7.9.0
- nl.basjes.parse.useragent:yauaa-drill (Maven): affected from 7.0.0; fixed in 7.9.0
- nl.basjes.parse.useragent:yauaa-elasticsearch (Maven): affected from 7.0.0; fixed in 7.9.0
- nl.basjes.parse.useragent:yauaa-elasticsearch (Maven): affected from 7.0.0; fixed in 7.9.0
- nl.basjes.parse.useragent:yauaa-elasticsearch-8 (Maven): affected from 7.0.0; fixed in 7.9.0
- nl.basjes.parse.useragent:yauaa-elasticsearch-8 (Maven): affected from 7.0.0; fixed in 7.9.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-23496/ (Markdown: https://insights.sbomify.com/CVE-2022-23496/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-23496
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-23496
- OSV: https://osv.dev/vulnerability/CVE-2022-23496

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-23496/
Summaries are generated and may contain mistakes; the official description above is the record.
