# CVE-2022-23500: TYPO3 subject to Uncontrolled Recursion resulting in Denial of Service

> Attackers can cause a denial of service in TYPO3 by triggering uncontrolled recursion through invalid resource requests, exhausting server resources.

- **Severity:** Medium 5.9 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Dec 2022
- **Updated:** 21 Apr 2025
- **Also known as:** BIT-typo3-2022-23500, GHSA-8c28-5mp7-v24h

## What is CVE-2022-23500?

CVE-2022-23500 is a medium-severity denial of service vulnerability in Typo3 Typo3, published on 14 Dec 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

TYPO3 is an open source PHP based web content management system. In versions prior to 9.5.38, 10.4.33, 11.5.20, and 12.1.1, requesting invalid or non-existing resources via HTTP triggers the page error handler, which again could retrieve content to be shown as an error message from another page. This leads to a scenario in which the application is calling itself recursively - amplifying the impact of the initial attack until the limits of the web server are exceeded. This vulnerability is very similar, but not identical, to the one described in CVE-2021-21359. This issue is patched in versions 9.5.38 ELTS, 10.4.33, 11.5.20 or 12.1.1.

Weakness: CWE-674 (Uncontrolled Recursion)

## Which versions are affected by CVE-2022-23500?

11 open source packages ship an affected version, including typo3/cms-core, typo3 and typo3/cms. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `typo3/cms-core` | Packagist | From 10.0.0 | 10.4.33 |
| `typo3/cms-core` | Packagist | From 10.0.0 | 10.4.33 |
| `typo3/cms-core` | Packagist | From 11.0.0 | 11.5.20 |
| `typo3/cms-core` | Packagist | From 11.0.0 | 11.5.20 |
| `typo3/cms-core` | Packagist | From 9.0.0 | 9.5.38 |
| `typo3/cms-core` | Packagist | From 9.0.0 | 9.5.38 |
| `typo3` | Bitnami | From 9.0.0 | 9.5.38, 10.4.33, 11.5.20 |
| `typo3/cms` | Packagist | From 10.0.0 | 10.4.33 |
| `typo3/cms` | Packagist | From 10.0.0 | 10.4.33 |
| `typo3/cms` | Packagist | From 11.0.0 | 11.5.20 |
| `typo3/cms` | Packagist | From 11.0.0 | 11.5.20 |

Products: Typo3 Typo3.

## How do I fix CVE-2022-23500?

Upgrade typo3/cms-core to a fixed version for your release line: 10.4.33, 11.5.20 or 9.5.38.

## Is CVE-2022-23500 being exploited?

There is no known exploitation of CVE-2022-23500 in the wild and no public exploit code.

## Other vulnerabilities in Typo3 Typo3

- [CVE-2009-0258](https://insights.sbomify.com/CVE-2009-0258/): Indexed Search Engine for TYPO3 Command Execution via Metacharacter Injection (critical 10.0)
- [CVE-2011-3583](https://insights.sbomify.com/CVE-2011-3583/): Typo3 SQL injection due to faulty prepared statements (critical 9.8)
- [CVE-2011-4628](https://insights.sbomify.com/CVE-2011-4628/): Typo3 Authentication Bypass (critical 9.8)
- [CVE-2023-24814](https://insights.sbomify.com/CVE-2023-24814/): Persisted Cross-Site Scripting in Frontend Rendering in typo3 (high 8.8)
- [CVE-2021-41113](https://insights.sbomify.com/CVE-2021-41113/): Cross-Site-Request-Forgery in Backend URI Handling in Typo3 (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-23500 and fix it if it is affected.

What it is: CVE-2022-23500 is a medium-severity denial of service vulnerability in Typo3 Typo3, published on 14 Dec 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-23500 in the wild and no public exploit code.

Affected packages and fixed versions:
- typo3/cms-core (Packagist): affected from 10.0.0; fixed in 10.4.33
- typo3/cms-core (Packagist): affected from 10.0.0; fixed in 10.4.33
- typo3/cms-core (Packagist): affected from 11.0.0; fixed in 11.5.20
- typo3/cms-core (Packagist): affected from 11.0.0; fixed in 11.5.20
- typo3/cms-core (Packagist): affected from 9.0.0; fixed in 9.5.38
- typo3/cms-core (Packagist): affected from 9.0.0; fixed in 9.5.38
- typo3 (Bitnami): affected from 9.0.0; fixed in 9.5.38, 10.4.33, 11.5.20
- typo3/cms (Packagist): affected from 10.0.0; fixed in 10.4.33
- typo3/cms (Packagist): affected from 10.0.0; fixed in 10.4.33
- typo3/cms (Packagist): affected from 11.0.0; fixed in 11.5.20
- typo3/cms (Packagist): affected from 11.0.0; fixed in 11.5.20

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-23500/ (Markdown: https://insights.sbomify.com/CVE-2022-23500/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-23500
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-23500
- OSV: https://osv.dev/vulnerability/CVE-2022-23500

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-23500/
Summaries are generated and may contain mistakes; the official description above is the record.
