CVE-2022-23501 TYPO3 vulnerable to Improper Authentication in Frontend Login
Attackers with known credentials can bypass frontend login restrictions to access different user accounts in TYPO3.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2022-23501?
CVE-2022-23501 is a medium-severity authentication bypass vulnerability in Typo3 Typo3, published on 14 Dec 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
TYPO3 is an open source PHP based web content management system. In versions prior to 8.7.49, 9.5.38, 10.4.33, 11.5.20, and 12.1.1 TYPO3 is vulnerable to Improper Authentication. Restricting frontend login to specific users, organized in different storage folders (partitions), can be bypassed. A potential attacker might use this ambiguity in usernames to get access to a different account - however, credentials must be known to the adversary. This issue is patched in versions 8.7.49 ELTS, 9.5.38 ELTS, 10.4.33, 11.5.20, 12.1.1.
Weakness: CWE-287
Which versions are affected by CVE-2022-23501?
17 open source packages ship an affected version, including typo3/cms-core, typo3 and typo3/cms. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
typo3/cms-core Packagist | All versions | 8.7.49 |
typo3/cms-core Packagist | All versions | 8.7.49 |
typo3/cms-core Packagist | From 10.0.0 | 10.4.33 |
typo3/cms-core Packagist | From 10.0.0 | 10.4.33 |
typo3/cms-core Packagist | From 11.0.0 | 11.5.20 |
typo3/cms-core Packagist | From 11.0.0 | 11.5.20 |
11 more packages
typo3/cms-core Packagist | From 12.0.0 | 12.1.1 |
typo3/cms-core Packagist | From 12.0.0 | 12.1.1 |
typo3/cms-core Packagist | From 9.0.0 | 9.5.38 |
typo3/cms-core Packagist | From 9.0.0 | 9.5.38 |
typo3 Bitnami | All versions | 8.7.49, 9.5.38, 10.4.33, 11.5.20, 12.1.1 |
typo3/cms Packagist | From 10.0.0 | 10.4.33 |
typo3/cms Packagist | From 10.0.0 | 10.4.33 |
typo3/cms Packagist | From 11.0.0 | 11.5.20 |
typo3/cms Packagist | From 11.0.0 | 11.5.20 |
typo3/cms Packagist | From 12.0.0 | 12.1.1 |
typo3/cms Packagist | From 12.0.0 | 12.1.1 |
Products include Typo3 Typo3.
How do I fix CVE-2022-23501?
Upgrade typo3/cms-core to a fixed version for your release line: 8.7.49, 10.4.33, 11.5.20 or 12.1.1.
Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.
Is CVE-2022-23501 being exploited?
There is no known exploitation of CVE-2022-23501 in the wild and no public exploit code.
Other vulnerabilities in Typo3 Typo3
- CVE-2009-0258 Indexed Search Engine for TYPO3 Command Execution via Metacharacter Injection
- CVE-2011-3583 Typo3 SQL injection due to faulty prepared statements
- CVE-2011-4628 Typo3 Authentication Bypass
- CVE-2023-24814 Persisted Cross-Site Scripting in Frontend Rendering in typo3
- CVE-2021-41113 Cross-Site-Request-Forgery in Backend URI Handling in Typo3
Sources
Also known as BIT-typo3-2022-23501, GHSA-jfp7-79g7-89rf.