CVE-2022-23502 TYPO3 contains Insufficient Session Expiration after Password Reset
Attackers can maintain access via old sessions after a user resets their password, potentially leading to account takeover.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2022-23502?
CVE-2022-23502 is a medium-severity vulnerability in Typo3 Typo3, published on 14 Dec 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
TYPO3 is an open source PHP based web content management system. In versions prior to 10.4.33, 11.5.20, and 12.1.1, When users reset their password using the corresponding password recovery functionality, existing sessions for that particular user account were not revoked. This applied to both frontend user sessions and backend user sessions. This issue is patched in versions 10.4.33, 11.5.20, 12.1.1.
Weakness: CWE-613
Which versions are affected by CVE-2022-23502?
13 open source packages ship an affected version, including typo3/cms, typo3 and typo3/cms-core. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
typo3/cms Packagist | From 10.0.0 | 10.4.33 |
typo3/cms Packagist | From 10.0.0 | 10.4.33 |
typo3/cms Packagist | From 11.0.0 | 11.5.20 |
typo3/cms Packagist | From 11.0.0 | 11.5.20 |
typo3/cms Packagist | From 12.0.0 | 12.1.1 |
typo3/cms Packagist | From 12.0.0 | 12.1.1 |
7 more packages
typo3 Bitnami | From 10.0.0 | 10.4.33, 11.5.20, 12.1.1 |
typo3/cms-core Packagist | From 10.0.0 | 10.4.33 |
typo3/cms-core Packagist | From 10.0.0 | 10.4.33 |
typo3/cms-core Packagist | From 11.0.0 | 11.5.20 |
typo3/cms-core Packagist | From 11.0.0 | 11.5.20 |
typo3/cms-core Packagist | From 12.0.0 | 12.1.1 |
typo3/cms-core Packagist | From 12.0.0 | 12.1.1 |
Products include Typo3 Typo3.
How do I fix CVE-2022-23502?
Upgrade typo3/cms to a fixed version for your release line: 10.4.33, 11.5.20 or 12.1.1.
Is CVE-2022-23502 being exploited?
There is no known exploitation of CVE-2022-23502 in the wild and no public exploit code.
Other vulnerabilities in Typo3 Typo3
- CVE-2009-0258 Indexed Search Engine for TYPO3 Command Execution via Metacharacter Injection
- CVE-2011-3583 Typo3 SQL injection due to faulty prepared statements
- CVE-2011-4628 Typo3 Authentication Bypass
- CVE-2023-24814 Persisted Cross-Site Scripting in Frontend Rendering in typo3
- CVE-2021-41113 Cross-Site-Request-Forgery in Backend URI Handling in Typo3
Sources
Also known as BIT-typo3-2022-23502, GHSA-mgj2-q8wp-29rr.