# CVE-2022-23502: TYPO3 contains Insufficient Session Expiration after Password Reset

> Attackers can maintain access via old sessions after a user resets their password, potentially leading to account takeover.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Dec 2022
- **Updated:** 21 Apr 2025
- **Also known as:** BIT-typo3-2022-23502, GHSA-mgj2-q8wp-29rr

## What is CVE-2022-23502?

CVE-2022-23502 is a medium-severity vulnerability in Typo3 Typo3, published on 14 Dec 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

TYPO3 is an open source PHP based web content management system. In versions prior to 10.4.33, 11.5.20, and 12.1.1, When users reset their password using the corresponding password recovery functionality, existing sessions for that particular user account were not revoked. This applied to both frontend user sessions and backend user sessions. This issue is patched in versions 10.4.33, 11.5.20, 12.1.1.

Weakness: CWE-613 (DEPRECATED: Insufficient Session Expiration)

## Which versions are affected by CVE-2022-23502?

13 open source packages ship an affected version, including typo3/cms, typo3 and typo3/cms-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `typo3/cms` | Packagist | From 10.0.0 | 10.4.33 |
| `typo3/cms` | Packagist | From 10.0.0 | 10.4.33 |
| `typo3/cms` | Packagist | From 11.0.0 | 11.5.20 |
| `typo3/cms` | Packagist | From 11.0.0 | 11.5.20 |
| `typo3/cms` | Packagist | From 12.0.0 | 12.1.1 |
| `typo3/cms` | Packagist | From 12.0.0 | 12.1.1 |
| `typo3` | Bitnami | From 10.0.0 | 10.4.33, 11.5.20, 12.1.1 |
| `typo3/cms-core` | Packagist | From 10.0.0 | 10.4.33 |
| `typo3/cms-core` | Packagist | From 10.0.0 | 10.4.33 |
| `typo3/cms-core` | Packagist | From 11.0.0 | 11.5.20 |
| `typo3/cms-core` | Packagist | From 11.0.0 | 11.5.20 |
| `typo3/cms-core` | Packagist | From 12.0.0 | 12.1.1 |
| `typo3/cms-core` | Packagist | From 12.0.0 | 12.1.1 |

Products: Typo3 Typo3.

## How do I fix CVE-2022-23502?

Upgrade typo3/cms to a fixed version for your release line: 10.4.33, 11.5.20 or 12.1.1.

## Is CVE-2022-23502 being exploited?

There is no known exploitation of CVE-2022-23502 in the wild and no public exploit code.

## Other vulnerabilities in Typo3 Typo3

- [CVE-2009-0258](https://insights.sbomify.com/CVE-2009-0258/): Indexed Search Engine for TYPO3 Command Execution via Metacharacter Injection (critical 10.0)
- [CVE-2011-3583](https://insights.sbomify.com/CVE-2011-3583/): Typo3 SQL injection due to faulty prepared statements (critical 9.8)
- [CVE-2011-4628](https://insights.sbomify.com/CVE-2011-4628/): Typo3 Authentication Bypass (critical 9.8)
- [CVE-2023-24814](https://insights.sbomify.com/CVE-2023-24814/): Persisted Cross-Site Scripting in Frontend Rendering in typo3 (high 8.8)
- [CVE-2021-41113](https://insights.sbomify.com/CVE-2021-41113/): Cross-Site-Request-Forgery in Backend URI Handling in Typo3 (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-23502 and fix it if it is affected.

What it is: CVE-2022-23502 is a medium-severity vulnerability in Typo3 Typo3, published on 14 Dec 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-23502 in the wild and no public exploit code.

Affected packages and fixed versions:
- typo3/cms (Packagist): affected from 10.0.0; fixed in 10.4.33
- typo3/cms (Packagist): affected from 10.0.0; fixed in 10.4.33
- typo3/cms (Packagist): affected from 11.0.0; fixed in 11.5.20
- typo3/cms (Packagist): affected from 11.0.0; fixed in 11.5.20
- typo3/cms (Packagist): affected from 12.0.0; fixed in 12.1.1
- typo3/cms (Packagist): affected from 12.0.0; fixed in 12.1.1
- typo3 (Bitnami): affected from 10.0.0; fixed in 10.4.33, 11.5.20, 12.1.1
- typo3/cms-core (Packagist): affected from 10.0.0; fixed in 10.4.33
- typo3/cms-core (Packagist): affected from 10.0.0; fixed in 10.4.33
- typo3/cms-core (Packagist): affected from 11.0.0; fixed in 11.5.20
- typo3/cms-core (Packagist): affected from 11.0.0; fixed in 11.5.20
- typo3/cms-core (Packagist): affected from 12.0.0; fixed in 12.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-23502/ (Markdown: https://insights.sbomify.com/CVE-2022-23502/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-23502
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-23502
- OSV: https://osv.dev/vulnerability/CVE-2022-23502

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-23502/
Summaries are generated and may contain mistakes; the official description above is the record.
