CVE-2022-23503 TYPO3 vulnerable to Arbitrary Code Execution via Form Framework
Authenticated backend users can inject and execute arbitrary PHP code via the Form Designer module in TYPO3.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2022-23503?
CVE-2022-23503 is a high-severity code injection vulnerability in Typo3 Typo3, published on 14 Dec 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
TYPO3 is an open source PHP based web content management system. Versions prior to 8.7.49, 9.5.38, 10.4.33, 11.5.20, and 12.1.1 are vulnerable to Code Injection. Due to the lack of separating user-submitted data from the internal configuration in the Form Designer backend module, it is possible to inject code instructions to be processed and executed via TypoScript as PHP code. The existence of individual TypoScript instructions for a particular form item and a valid backend user account with access to the form module are needed to exploit this vulnerability. This issue is patched in versions 8.7.49 ELTS, 9.5.38 ELTS, 10.4.33, 11.5.20, 12.1.1.
Weakness: CWE-94
Which versions are affected by CVE-2022-23503?
17 open source packages ship an affected version, including typo3/cms-core, typo3 and typo3/cms. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
typo3/cms-core Packagist | From 10.0.0 | 10.4.33 |
typo3/cms-core Packagist | From 10.0.0 | 10.4.33 |
typo3/cms-core Packagist | From 11.0.0 | 11.5.20 |
typo3/cms-core Packagist | From 11.0.0 | 11.5.20 |
typo3/cms-core Packagist | From 12.0.0 | 12.1.1 |
typo3/cms-core Packagist | From 12.0.0 | 12.1.1 |
11 more packages
typo3/cms-core Packagist | From 8.0.0 | 8.7.49 |
typo3/cms-core Packagist | From 8.0.0 | 8.7.49 |
typo3/cms-core Packagist | From 9.0.0 | 9.5.38 |
typo3/cms-core Packagist | From 9.0.0 | 9.5.38 |
typo3 Bitnami | From 8.0.0 | 8.7.49, 9.5.38, 10.4.33, 11.5.20, 12.1.1 |
typo3/cms Packagist | From 10.0.0 | 10.4.33 |
typo3/cms Packagist | From 10.0.0 | 10.4.33 |
typo3/cms Packagist | From 11.0.0 | 11.5.20 |
typo3/cms Packagist | From 11.0.0 | 11.5.20 |
typo3/cms Packagist | From 12.0.0 | 12.1.1 |
typo3/cms Packagist | From 12.0.0 | 12.1.1 |
Products include Typo3 Typo3.
How do I fix CVE-2022-23503?
Upgrade typo3/cms-core to a fixed version for your release line: 10.4.33, 11.5.20, 12.1.1 or 8.7.49.
Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.
Is CVE-2022-23503 being exploited?
There is no known exploitation of CVE-2022-23503 in the wild and no public exploit code.
Other vulnerabilities in Typo3 Typo3
- CVE-2009-0258 Indexed Search Engine for TYPO3 Command Execution via Metacharacter Injection
- CVE-2011-3583 Typo3 SQL injection due to faulty prepared statements
- CVE-2011-4628 Typo3 Authentication Bypass
- CVE-2023-24814 Persisted Cross-Site Scripting in Frontend Rendering in typo3
- CVE-2021-41113 Cross-Site-Request-Forgery in Backend URI Handling in Typo3
Sources
Also known as BIT-typo3-2022-23503, GHSA-c5wx-6c2c-f7rm.