# CVE-2022-23503: TYPO3 vulnerable to Arbitrary Code Execution via Form Framework

> Authenticated backend users can inject and execute arbitrary PHP code via the Form Designer module in TYPO3.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Dec 2022
- **Updated:** 18 Apr 2025
- **Also known as:** BIT-typo3-2022-23503, GHSA-c5wx-6c2c-f7rm

## What is CVE-2022-23503?

CVE-2022-23503 is a high-severity code injection vulnerability in Typo3 Typo3, published on 14 Dec 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

TYPO3 is an open source PHP based web content management system. Versions prior to 8.7.49, 9.5.38, 10.4.33, 11.5.20, and 12.1.1 are vulnerable to Code Injection. Due to the lack of separating user-submitted data from the internal configuration in the Form Designer backend module, it is possible to inject code instructions to be processed and executed via TypoScript as PHP code. The existence of individual TypoScript instructions for a particular form item and a valid backend user account with access to the form module are needed to exploit this vulnerability. This issue is patched in versions 8.7.49 ELTS, 9.5.38 ELTS, 10.4.33, 11.5.20, 12.1.1.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2022-23503?

17 open source packages ship an affected version, including typo3/cms-core, typo3 and typo3/cms. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `typo3/cms-core` | Packagist | From 10.0.0 | 10.4.33 |
| `typo3/cms-core` | Packagist | From 10.0.0 | 10.4.33 |
| `typo3/cms-core` | Packagist | From 11.0.0 | 11.5.20 |
| `typo3/cms-core` | Packagist | From 11.0.0 | 11.5.20 |
| `typo3/cms-core` | Packagist | From 12.0.0 | 12.1.1 |
| `typo3/cms-core` | Packagist | From 12.0.0 | 12.1.1 |
| `typo3/cms-core` | Packagist | From 8.0.0 | 8.7.49 |
| `typo3/cms-core` | Packagist | From 8.0.0 | 8.7.49 |
| `typo3/cms-core` | Packagist | From 9.0.0 | 9.5.38 |
| `typo3/cms-core` | Packagist | From 9.0.0 | 9.5.38 |
| `typo3` | Bitnami | From 8.0.0 | 8.7.49, 9.5.38, 10.4.33, 11.5.20, 12.1.1 |
| `typo3/cms` | Packagist | From 10.0.0 | 10.4.33 |
| `typo3/cms` | Packagist | From 10.0.0 | 10.4.33 |
| `typo3/cms` | Packagist | From 11.0.0 | 11.5.20 |
| `typo3/cms` | Packagist | From 11.0.0 | 11.5.20 |
| `typo3/cms` | Packagist | From 12.0.0 | 12.1.1 |
| `typo3/cms` | Packagist | From 12.0.0 | 12.1.1 |

Products: Typo3 Typo3.

## How do I fix CVE-2022-23503?

Upgrade typo3/cms-core to a fixed version for your release line: 10.4.33, 11.5.20, 12.1.1 or 8.7.49.

## Is CVE-2022-23503 being exploited?

There is no known exploitation of CVE-2022-23503 in the wild and no public exploit code.

## Other vulnerabilities in Typo3 Typo3

- [CVE-2009-0258](https://insights.sbomify.com/CVE-2009-0258/): Indexed Search Engine for TYPO3 Command Execution via Metacharacter Injection (critical 10.0)
- [CVE-2011-3583](https://insights.sbomify.com/CVE-2011-3583/): Typo3 SQL injection due to faulty prepared statements (critical 9.8)
- [CVE-2011-4628](https://insights.sbomify.com/CVE-2011-4628/): Typo3 Authentication Bypass (critical 9.8)
- [CVE-2023-24814](https://insights.sbomify.com/CVE-2023-24814/): Persisted Cross-Site Scripting in Frontend Rendering in typo3 (high 8.8)
- [CVE-2021-41113](https://insights.sbomify.com/CVE-2021-41113/): Cross-Site-Request-Forgery in Backend URI Handling in Typo3 (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-23503 and fix it if it is affected.

What it is: CVE-2022-23503 is a high-severity code injection vulnerability in Typo3 Typo3, published on 14 Dec 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-23503 in the wild and no public exploit code.

Affected packages and fixed versions:
- typo3/cms-core (Packagist): affected from 10.0.0; fixed in 10.4.33
- typo3/cms-core (Packagist): affected from 10.0.0; fixed in 10.4.33
- typo3/cms-core (Packagist): affected from 11.0.0; fixed in 11.5.20
- typo3/cms-core (Packagist): affected from 11.0.0; fixed in 11.5.20
- typo3/cms-core (Packagist): affected from 12.0.0; fixed in 12.1.1
- typo3/cms-core (Packagist): affected from 12.0.0; fixed in 12.1.1
- typo3/cms-core (Packagist): affected from 8.0.0; fixed in 8.7.49
- typo3/cms-core (Packagist): affected from 8.0.0; fixed in 8.7.49
- typo3/cms-core (Packagist): affected from 9.0.0; fixed in 9.5.38
- typo3/cms-core (Packagist): affected from 9.0.0; fixed in 9.5.38
- typo3 (Bitnami): affected from 8.0.0; fixed in 8.7.49, 9.5.38, 10.4.33, 11.5.20, 12.1.1
- typo3/cms (Packagist): affected from 10.0.0; fixed in 10.4.33

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-23503/ (Markdown: https://insights.sbomify.com/CVE-2022-23503/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-23503
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-23503
- OSV: https://osv.dev/vulnerability/CVE-2022-23503

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-23503/
Summaries are generated and may contain mistakes; the official description above is the record.
