CVE-2022-23504 TYPO3 contains Sensitive Information Disclosure via YAML Placeholder Expressions in Site Configuration
Authenticated administrators can expose sensitive internal information via YAML placeholder expressions in TYPO3 site configuration.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2022-23504?
CVE-2022-23504 is a medium-severity vulnerability in Typo3 Typo3, published on 14 Dec 2022. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Official description
TYPO3 is an open source PHP based web content management system. Versions prior to 9.5.38, 10.4.33, 11.5.20, and 12.1.1 are subject to Sensitive Information Disclosure. Due to the lack of handling user-submitted YAML placeholder expressions in the site configuration backend module, attackers could expose sensitive internal information, such as system configuration or HTTP request messages of other website visitors. A valid backend user account having administrator privileges is needed to exploit this vulnerability. This issue has been patched in versions 9.5.38 ELTS, 10.4.33, 11.5.20, 12.1.1.
Which versions are affected by CVE-2022-23504?
15 open source packages ship an affected version, including typo3/cms-core, typo3 and typo3/cms. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
typo3/cms-core Packagist | From 10.0.0 | 10.4.33 |
typo3/cms-core Packagist | From 10.0.0 | 10.4.33 |
typo3/cms-core Packagist | From 11.0.0 | 11.5.20 |
typo3/cms-core Packagist | From 11.0.0 | 11.5.20 |
typo3/cms-core Packagist | From 12.0.0 | 12.1.1 |
typo3/cms-core Packagist | From 12.0.0 | 12.1.1 |
9 more packages
typo3/cms-core Packagist | From 9.0.0 | 9.5.38 |
typo3/cms-core Packagist | From 9.0.0 | 9.5.38 |
typo3 Bitnami | From 9.0.0 | 9.5.38, 10.4.33, 11.5.20, 12.1.1 |
typo3/cms Packagist | From 10.0.0 | 10.4.33 |
typo3/cms Packagist | From 10.0.0 | 10.4.33 |
typo3/cms Packagist | From 11.0.0 | 11.5.20 |
typo3/cms Packagist | From 11.0.0 | 11.5.20 |
typo3/cms Packagist | From 12.0.0 | 12.1.1 |
typo3/cms Packagist | From 12.0.0 | 12.1.1 |
Products include Typo3 Typo3.
How do I fix CVE-2022-23504?
Upgrade typo3/cms-core to a fixed version for your release line: 10.4.33, 11.5.20, 12.1.1 or 9.5.38.
Is CVE-2022-23504 being exploited?
There is no known exploitation of CVE-2022-23504 in the wild and no public exploit code.
Other vulnerabilities in Typo3 Typo3
- CVE-2009-0258 Indexed Search Engine for TYPO3 Command Execution via Metacharacter Injection
- CVE-2011-3583 Typo3 SQL injection due to faulty prepared statements
- CVE-2011-4628 Typo3 Authentication Bypass
- CVE-2023-24814 Persisted Cross-Site Scripting in Frontend Rendering in typo3
- CVE-2021-41113 Cross-Site-Request-Forgery in Backend URI Handling in Typo3
Sources
Also known as BIT-typo3-2022-23504, GHSA-8w3p-qh3x-6gjr.