{"answers":{"affected":"2 open source packages ship an affected version, including passport-wsfed-saml2. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-23505 in the wild and no public exploit code.","fix":"Upgrade passport-wsfed-saml2 to 4.6.3 or later.","what":"CVE-2022-23505 is a medium-severity authentication bypass vulnerability in auth0 passport-wsfed-saml2, published on 13 Dec 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-23505 and fix it if it is affected.\n\nWhat it is: CVE-2022-23505 is a medium-severity authentication bypass vulnerability in auth0 passport-wsfed-saml2, published on 13 Dec 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-23505 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- passport-wsfed-saml2 (npm): affected all versions; fixed in 4.6.3\n- passport-wsfed-saml2 (npm): affected all versions; fixed in 4.6.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-23505/ (Markdown: https://insights.sbomify.com/CVE-2022-23505/index.md)","id":"CVE-2022-23505","markdown":"https://insights.sbomify.com/CVE-2022-23505/index.md","name":"CVE-2022-23505","record":{"aliases":["GHSA-ppjq-qxhx-m25f"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js authentication library","requires_auth":"none","summary":"Remote attackers can bypass WSFed authentication in passport-wsfed-saml2 by using arbitrary signed assertions, potentially gaining unauthorized access.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"passport-wsfed-saml2","vendor":"auth0"}],"cvss":{"score":5.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-287","name":"Improper Authentication"}],"description":"Passport-wsfed-saml2 is a ws-federation protocol and SAML2 tokens authentication provider for Passport. In versions prior to 4.6.3, a remote attacker may be able to bypass WSFed authentication on a website using passport-wsfed-saml2. A successful attack requires that the attacker is in possession of an arbitrary IDP signed assertion. Depending on the IDP used, fully unauthenticated attacks (e.g without access to a valid user) might also be feasible if generation of a signed message can be triggered. This issue is patched in version 4.6.3. Use of SAML2 authentication instead of WSFed is a workaround.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Passport-wsfed-saml2 vulnerable to Authentication Bypass for WSFed authentication","id":"CVE-2022-23505","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"auth_bypass","year":"2022"},"n_packages":2,"n_references":1,"next":{"headline":"Spinnaker's Rosco microservice vulnerable to improper log masking on AWS Packer builds","id":"CVE-2022-23506"},"packages":[{"ecosystem":"npm","fixed":["4.6.3"],"introduced":["0"],"last_affected":[],"package":"passport-wsfed-saml2","purl":null,"source":"GHSA-ppjq-qxhx-m25f"},{"ecosystem":"npm","fixed":["4.6.3"],"introduced":["0"],"last_affected":[],"package":"passport-wsfed-saml2","purl":"pkg:npm/passport-wsfed-saml2","source":"GHSA-ppjq-qxhx-m25f"}],"prev":{"headline":"TYPO3 contains Sensitive Information Disclosure via YAML Placeholder Expressions in Site Configuration","id":"CVE-2022-23504"},"products":["passport-wsfed-saml2"],"published":"2022-12-13","related":[{"cvss_score":8.1,"headline":"passport-wsfed-saml2 vulnerable to Signature Bypass in SAML2 token","id":"CVE-2017-16897","kev_date_added":null,"published":"2017-12-23"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-23","vendors":["auth0"]},"summary":"Remote attackers can bypass WSFed authentication in passport-wsfed-saml2 by using arbitrary signed assertions, potentially gaining unauthorized access.","url":"https://insights.sbomify.com/CVE-2022-23505/"}