# CVE-2022-23509: Weave Gitops Run vulnerable to insecure communication

> Unencrypted local S3 communication allows attackers to intercept credentials and modify Kubernetes cluster resources via the GitOps Run tool.

- **Severity:** High 7.4 (`CVSS:3.1/AV:A/AC:H/PR:H/UI:R/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 9 Jan 2023
- **Updated:** 10 Mar 2025
- **Also known as:** GHSA-89qm-wcmw-3mgg, GO-2023-1388

## What is CVE-2022-23509?

CVE-2022-23509 is a high-severity vulnerability in weaveworks weave-gitops, published on 9 Jan 2023. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

Weave GitOps is a simple open source developer platform for people who want cloud native applications, without needing Kubernetes expertise. GitOps run has a local S3 bucket which it uses for synchronizing files that are later applied against a Kubernetes cluster. The communication between GitOps Run and the local S3 bucket is not encrypted. This allows privileged users or process to tap the local traffic to gain information permitting access to the s3 bucket. From that point, it would be possible to alter the bucket content, resulting in changes in the Kubernetes cluster's resources. There are no known workaround(s) for this vulnerability. This vulnerability has been fixed by commits ce2bbff and babd915. Users should upgrade to Weave GitOps version >= v0.12.0 released on 08/12/2022.

Weakness: CWE-319 (Cleartext Transmission of Sensitive Information), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2022-23509?

3 open source packages ship an affected version, including github.com/weaveworks/weave-gitops. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/weaveworks/weave-gitops` | Go | All versions | 0.12.0 |
| `github.com/weaveworks/weave-gitops` | Go | All versions | 0.12.0 |
| `github.com/weaveworks/weave-gitops` | Go | All versions | 0.12.0 |

Products: Weave Weave Gitops.

## How do I fix CVE-2022-23509?

Upgrade github.com/weaveworks/weave-gitops to 0.12.0 or later.

## Is CVE-2022-23509 being exploited?

There is no known exploitation of CVE-2022-23509 in the wild and no public exploit code.

## Other vulnerabilities in weaveworks weave-gitops

- [CVE-2022-31098](https://insights.sbomify.com/CVE-2022-31098/): Weave GitOps leaked cluster credentials into logs on connection errors (critical 9.0)
- [CVE-2022-23508](https://insights.sbomify.com/CVE-2022-23508/): GitOps Run allows for Kubernetes workload injection (high 8.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-23509 and fix it if it is affected.

What it is: CVE-2022-23509 is a high-severity vulnerability in weaveworks weave-gitops, published on 9 Jan 2023. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-23509 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/weaveworks/weave-gitops (Go): affected all versions; fixed in 0.12.0
- github.com/weaveworks/weave-gitops (Go): affected all versions; fixed in 0.12.0
- github.com/weaveworks/weave-gitops (Go): affected all versions; fixed in 0.12.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-23509/ (Markdown: https://insights.sbomify.com/CVE-2022-23509/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-23509
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-23509
- OSV: https://osv.dev/vulnerability/CVE-2022-23509

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-23509/
Summaries are generated and may contain mistakes; the official description above is the record.
