{"answers":{"affected":"2 open source packages ship an affected version, including @cubejs-backend/api-gateway. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-23510 in the wild and no public exploit code.","fix":"Upgrade @cubejs-backend/api-gateway to 0.31.24 or later.","what":"CVE-2022-23510 is a critical SQL injection vulnerability in cube-js cube.js, published on 9 Dec 2022. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-23510 and fix it if it is affected.\n\nWhat it is: CVE-2022-23510 is a critical SQL injection vulnerability in cube-js cube.js, published on 9 Dec 2022. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-23510 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- @cubejs-backend/api-gateway (npm): affected from 0.31.23; fixed in 0.31.24\n- @cubejs-backend/api-gateway (npm): affected from 0.31.23; fixed in 0.31.24\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-23510/ (Markdown: https://insights.sbomify.com/CVE-2022-23510/index.md)","id":"CVE-2022-23510","markdown":"https://insights.sbomify.com/CVE-2022-23510/index.md","name":"CVE-2022-23510","record":{"aliases":["GHSA-6jqm-3c9g-pch7"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"Business intelligence platform","requires_auth":"low_privilege","summary":"Authenticated users can bypass row-level security and execute arbitrary SQL queries via the sql-runner endpoint in cube-js.","user_interaction":"not_required","vuln_class":"sql_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"cube.js","vendor":"cube"}],"cvss":{"score":9.6,"severity":"critical","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-89","name":"Improper Neutralization of Special Elements used in an SQL Command"}],"description":"cube-js is a headless business intelligence platform. In version 0.31.23 all authenticated Cube clients could bypass SQL row-level security and run arbitrary SQL via the newly introduced /v1/sql-runner endpoint. This issue has been resolved in version 0.31.24. Users are advised to either upgrade to 0.31.24 or to downgrade to 0.31.22. There are no known workarounds for this vulnerability.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"SQl injection in cube-js","id":"CVE-2022-23510","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"sql_injection","year":"2022"},"n_packages":2,"n_references":3,"next":{"headline":"Amazon CloudWatch Agent for Windows has Privilege Escalation Vector","id":"CVE-2022-23511"},"packages":[{"ecosystem":"npm","fixed":["0.31.24"],"introduced":["0.31.23"],"last_affected":[],"package":"@cubejs-backend/api-gateway","purl":null,"source":"GHSA-6jqm-3c9g-pch7"},{"ecosystem":"npm","fixed":["0.31.24"],"introduced":["0.31.23"],"last_affected":[],"package":"@cubejs-backend/api-gateway","purl":"pkg:npm/%40cubejs-backend/api-gateway","source":"GHSA-6jqm-3c9g-pch7"}],"prev":{"headline":"Weave Gitops Run vulnerable to insecure communication","id":"CVE-2022-23509"},"products":["cube.js"],"published":"2022-12-09","related":[{"cvss_score":7.7,"headline":"Cube privilege escalation via a specially crafted request","id":"CVE-2026-25958","kev_date_added":null,"published":"2026-02-09"},{"cvss_score":6.5,"headline":"Cube Denial of Service (DoS) - An authenticated attacker can crash the server by sending a specially crafted request","id":"CVE-2026-25957","kev_date_added":null,"published":"2026-02-09"},{"cvss_score":6.5,"headline":"Denial of service attack on the cube-api endpoint","id":"CVE-2023-50709","kev_date_added":null,"published":"2023-12-13"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-04-23","vendors":["cube-js"]},"summary":"Authenticated users can bypass row-level security and execute arbitrary SQL queries via the sql-runner endpoint in cube-js.","url":"https://insights.sbomify.com/CVE-2022-23510/"}