# CVE-2022-23510: SQl injection in cube-js

> Authenticated users can bypass row-level security and execute arbitrary SQL queries via the sql-runner endpoint in cube-js.

- **Severity:** Critical 9.6 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Dec 2022
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-6jqm-3c9g-pch7

## What is CVE-2022-23510?

CVE-2022-23510 is a critical SQL injection vulnerability in cube-js cube.js, published on 9 Dec 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

cube-js is a headless business intelligence platform. In version 0.31.23 all authenticated Cube clients could bypass SQL row-level security and run arbitrary SQL via the newly introduced /v1/sql-runner endpoint. This issue has been resolved in version 0.31.24. Users are advised to either upgrade to 0.31.24 or to downgrade to 0.31.22. There are no known workarounds for this vulnerability.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2022-23510?

2 open source packages ship an affected version, including @cubejs-backend/api-gateway. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@cubejs-backend/api-gateway` | npm | From 0.31.23 | 0.31.24 |
| `@cubejs-backend/api-gateway` | npm | From 0.31.23 | 0.31.24 |

Products: Cube Cube.js.

## How do I fix CVE-2022-23510?

Upgrade @cubejs-backend/api-gateway to 0.31.24 or later.

## Is CVE-2022-23510 being exploited?

There is no known exploitation of CVE-2022-23510 in the wild and no public exploit code.

## Other vulnerabilities in cube-js cube.js

- [CVE-2026-25958](https://insights.sbomify.com/CVE-2026-25958/): Cube privilege escalation via a specially crafted request (high 7.7)
- [CVE-2026-25957](https://insights.sbomify.com/CVE-2026-25957/): Cube Denial of Service (DoS) - An authenticated attacker can crash the server by sending a specially crafted request (medium 6.5)
- [CVE-2023-50709](https://insights.sbomify.com/CVE-2023-50709/): Denial of service attack on the cube-api endpoint (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-23510 and fix it if it is affected.

What it is: CVE-2022-23510 is a critical SQL injection vulnerability in cube-js cube.js, published on 9 Dec 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-23510 in the wild and no public exploit code.

Affected packages and fixed versions:
- @cubejs-backend/api-gateway (npm): affected from 0.31.23; fixed in 0.31.24
- @cubejs-backend/api-gateway (npm): affected from 0.31.23; fixed in 0.31.24

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-23510/ (Markdown: https://insights.sbomify.com/CVE-2022-23510/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-23510
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-23510
- OSV: https://osv.dev/vulnerability/CVE-2022-23510

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-23510/
Summaries are generated and may contain mistakes; the official description above is the record.
