{"answers":{"affected":"2 open source packages ship an affected version, including loofah. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-23514 exists.","fix":"Upgrade loofah to 2.19.1 or later.","what":"CVE-2022-23514 is a high-severity denial of service vulnerability in flavorjones loofah, published on 14 Dec 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-23514 and fix it if it is affected.\n\nWhat it is: CVE-2022-23514 is a high-severity denial of service vulnerability in flavorjones loofah, published on 14 Dec 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-23514 exists.\n\nAffected packages and fixed versions:\n- loofah (RubyGems): affected all versions; fixed in 2.19.1\n- loofah (RubyGems): affected all versions; fixed in 2.19.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-23514/ (Markdown: https://insights.sbomify.com/CVE-2022-23514/index.md)","id":"CVE-2022-23514","markdown":"https://insights.sbomify.com/CVE-2022-23514/index.md","name":"CVE-2022-23514","record":{"aliases":["DEBIAN-CVE-2022-23514","GHSA-486f-hjj9-9vhh","UBUNTU-CVE-2022-23514"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Ruby HTML sanitization library","requires_auth":"none","summary":"Attackers can cause denial of service via CPU exhaustion by exploiting inefficient regular expressions in the Loofah library during SVG sanitization.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"loofah","vendor":"loofah_project"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-1333","name":"Inefficient Regular Expression Complexity"}],"description":"Loofah is a general library for manipulating and transforming HTML/XML documents and fragments, built on top of Nokogiri. Loofah \u003c 2.19.1 contains an inefficient regular expression that is susceptible to excessive backtracking when attempting to sanitize certain SVG attributes. This may lead to a denial of service through CPU resource consumption. This issue is patched in version 2.19.1.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Inefficient Regular Expression Complexity in Loofah","id":"CVE-2022-23514","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"denial_of_service","year":"2022"},"n_packages":2,"n_references":3,"next":{"headline":"Improper neutralization of data URIs may allow XSS in Loofah","id":"CVE-2022-23515"},"packages":[{"ecosystem":"RubyGems","fixed":["2.19.1"],"introduced":["0"],"last_affected":[],"package":"loofah","purl":null,"source":"GHSA-486f-hjj9-9vhh"},{"ecosystem":"RubyGems","fixed":["2.19.1"],"introduced":["0"],"last_affected":[],"package":"loofah","purl":"pkg:gem/loofah","source":"GHSA-486f-hjj9-9vhh"}],"prev":{"headline":"Pi-Hole/AdminLTE vulnerable due to improper access control in queryads endpoint","id":"CVE-2022-23513"},"products":["loofah"],"published":"2022-12-14","related":[{"cvss_score":7.5,"headline":"Uncontrolled Recursion in Loofah","id":"CVE-2022-23516","kev_date_added":null,"published":"2022-12-14"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-11-03","vendors":["flavorjones"]},"summary":"Attackers can cause denial of service via CPU exhaustion by exploiting inefficient regular expressions in the Loofah library during SVG sanitization.","url":"https://insights.sbomify.com/CVE-2022-23514/"}