# CVE-2022-23514: Inefficient Regular Expression Complexity in Loofah

> Attackers can cause denial of service via CPU exhaustion by exploiting inefficient regular expressions in the Loofah library during SVG sanitization.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Dec 2022
- **Updated:** 3 Nov 2025
- **Also known as:** DEBIAN-CVE-2022-23514, GHSA-486f-hjj9-9vhh, UBUNTU-CVE-2022-23514

## What is CVE-2022-23514?

CVE-2022-23514 is a high-severity denial of service vulnerability in flavorjones loofah, published on 14 Dec 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Loofah is a general library for manipulating and transforming HTML/XML documents and fragments, built on top of Nokogiri. Loofah < 2.19.1 contains an inefficient regular expression that is susceptible to excessive backtracking when attempting to sanitize certain SVG attributes. This may lead to a denial of service through CPU resource consumption. This issue is patched in version 2.19.1.

Weakness: CWE-1333 (Inefficient Regular Expression Complexity)

## Which versions are affected by CVE-2022-23514?

2 open source packages ship an affected version, including loofah. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `loofah` | RubyGems | All versions | 2.19.1 |
| `loofah` | RubyGems | All versions | 2.19.1 |

Products: Loofah Project Loofah.

## How do I fix CVE-2022-23514?

Upgrade loofah to 2.19.1 or later.

## Is CVE-2022-23514 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-23514 exists.

## Other vulnerabilities in flavorjones loofah

- [CVE-2022-23516](https://insights.sbomify.com/CVE-2022-23516/): Uncontrolled Recursion in Loofah (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-23514 and fix it if it is affected.

What it is: CVE-2022-23514 is a high-severity denial of service vulnerability in flavorjones loofah, published on 14 Dec 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-23514 exists.

Affected packages and fixed versions:
- loofah (RubyGems): affected all versions; fixed in 2.19.1
- loofah (RubyGems): affected all versions; fixed in 2.19.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-23514/ (Markdown: https://insights.sbomify.com/CVE-2022-23514/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-23514
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-23514
- OSV: https://osv.dev/vulnerability/CVE-2022-23514

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-23514/
Summaries are generated and may contain mistakes; the official description above is the record.
