{"answers":{"affected":"2 open source packages ship an affected version, including loofah. It affects 2 products.","exploited":"There is no known exploitation of CVE-2022-23515 in the wild and no public exploit code.","fix":"Upgrade loofah to 2.19.1 or later.","what":"CVE-2022-23515 is a medium-severity cross-site scripting vulnerability in Debian Debian Linux, published on 14 Dec 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2022-23515 and fix it if it is affected.\n\nWhat it is: CVE-2022-23515 is a medium-severity cross-site scripting vulnerability in Debian Debian Linux, published on 14 Dec 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2022-23515 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- loofah (RubyGems): affected from 2.1.0; fixed in 2.19.1\n- loofah (RubyGems): affected from 2.1.0; fixed in 2.19.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-23515/ (Markdown: https://insights.sbomify.com/CVE-2022-23515/index.md)","id":"CVE-2022-23515","markdown":"https://insights.sbomify.com/CVE-2022-23515/index.md","name":"CVE-2022-23515","record":{"aliases":["DEBIAN-CVE-2022-23515","GHSA-228g-948r-83gx","UBUNTU-CVE-2022-23515"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Ruby HTML library","requires_auth":"none","summary":"An attacker can execute arbitrary JavaScript in a victim's browser by exploiting improper handling of SVG data URIs in the Loofah library.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"debian_linux","vendor":"debian"},{"product":"loofah","vendor":"loofah_project"}],"cvss":{"score":6.1,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Loofah is a general library for manipulating and transforming HTML/XML documents and fragments, built on top of Nokogiri. Loofah \u003e= 2.1.0, \u003c 2.19.1 is vulnerable to cross-site scripting via the image/svg+xml media type in data URIs. This issue is patched in version 2.19.1.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Improper neutralization of data URIs may allow XSS in Loofah","id":"CVE-2022-23515","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":"debian:debian_linux","products":["debian:debian_linux"],"type":"xss","year":"2022"},"n_packages":2,"n_references":4,"next":{"headline":"Uncontrolled Recursion in Loofah","id":"CVE-2022-23516"},"packages":[{"ecosystem":"RubyGems","fixed":["2.19.1"],"introduced":["2.1.0"],"last_affected":[],"package":"loofah","purl":null,"source":"GHSA-228g-948r-83gx"},{"ecosystem":"RubyGems","fixed":["2.19.1"],"introduced":["2.1.0"],"last_affected":[],"package":"loofah","purl":"pkg:gem/loofah","source":"GHSA-228g-948r-83gx"}],"prev":{"headline":"Inefficient Regular Expression Complexity in Loofah","id":"CVE-2022-23514"},"products":["loofah"],"published":"2022-12-14","related":[{"cvss_score":10,"headline":"ProFTPD Improper Access Control","id":"CVE-2015-3306","kev_date_added":"2026-10-08","published":"2015-05-18"},{"cvss_score":9.9,"headline":"RoundCube Webmail Deserialization of Untrusted Data","id":"CVE-2025-49113","kev_date_added":"2026-02-20","published":"2025-06-02"},{"cvss_score":9.8,"headline":"GNU InetUtils Argument Injection","id":"CVE-2026-24061","kev_date_added":"2026-01-26","published":"2026-01-21"},{"cvss_score":9.8,"headline":"Linux Kernel Improper Check for Unusual or Exceptional Conditions","id":"CVE-2025-39682","kev_date_added":"2026-09-18","published":"2025-09-05"},{"cvss_score":9.8,"headline":"Mozilla Firefox Use-After-Free","id":"CVE-2024-9680","kev_date_added":"2024-10-15","published":"2024-10-09"},{"cvss_score":9.8,"headline":"RARLAB UnRAR Directory Traversal","id":"CVE-2022-30333","kev_date_added":"2022-08-09","published":"2022-05-09"},{"cvss_score":9.8,"headline":"Roundcube Webmail SQL Injection","id":"CVE-2021-44026","kev_date_added":"2023-06-22","published":"2021-11-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2025-11-03","vendors":["flavorjones"]},"summary":"An attacker can execute arbitrary JavaScript in a victim's browser by exploiting improper handling of SVG data URIs in the Loofah library.","url":"https://insights.sbomify.com/CVE-2022-23515/"}