# CVE-2022-23515: Improper neutralization of data URIs may allow XSS in Loofah

> An attacker can execute arbitrary JavaScript in a victim's browser by exploiting improper handling of SVG data URIs in the Loofah library.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 14 Dec 2022
- **Updated:** 3 Nov 2025
- **Also known as:** DEBIAN-CVE-2022-23515, GHSA-228g-948r-83gx, UBUNTU-CVE-2022-23515

## What is CVE-2022-23515?

CVE-2022-23515 is a medium-severity cross-site scripting vulnerability in Debian Debian Linux, published on 14 Dec 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Loofah is a general library for manipulating and transforming HTML/XML documents and fragments, built on top of Nokogiri. Loofah >= 2.1.0, < 2.19.1 is vulnerable to cross-site scripting via the image/svg+xml media type in data URIs. This issue is patched in version 2.19.1.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2022-23515?

2 open source packages ship an affected version, including loofah. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `loofah` | RubyGems | From 2.1.0 | 2.19.1 |
| `loofah` | RubyGems | From 2.1.0 | 2.19.1 |

Products: Debian Debian Linux, Loofah Project Loofah.

## How do I fix CVE-2022-23515?

Upgrade loofah to 2.19.1 or later.

## Is CVE-2022-23515 being exploited?

There is no known exploitation of CVE-2022-23515 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-23515 and fix it if it is affected.

What it is: CVE-2022-23515 is a medium-severity cross-site scripting vulnerability in Debian Debian Linux, published on 14 Dec 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-23515 in the wild and no public exploit code.

Affected packages and fixed versions:
- loofah (RubyGems): affected from 2.1.0; fixed in 2.19.1
- loofah (RubyGems): affected from 2.1.0; fixed in 2.19.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-23515/ (Markdown: https://insights.sbomify.com/CVE-2022-23515/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-23515
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-23515
- OSV: https://osv.dev/vulnerability/CVE-2022-23515

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-23515/
Summaries are generated and may contain mistakes; the official description above is the record.
