# CVE-2022-23516: Uncontrolled Recursion in Loofah


- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 14 Dec 2022
- **Updated:** 3 Nov 2025
- **Also known as:** DEBIAN-CVE-2022-23516, GHSA-3x8r-x6xp-q4vm, UBUNTU-CVE-2022-23516

## What is CVE-2022-23516?

CVE-2022-23516 is a high-severity vulnerability in flavorjones loofah, published on 14 Dec 2022. 

### Official description

Loofah is a general library for manipulating and transforming HTML/XML documents and fragments, built on top of Nokogiri. Loofah >= 2.2.0, < 2.19.1 uses recursion for sanitizing CDATA sections, making it susceptible to stack exhaustion and raising a SystemStackError exception.  This may lead to a denial of service through CPU resource consumption. This issue is patched in version 2.19.1. Users who are unable to upgrade may be able to mitigate this vulnerability by limiting the length of the strings that are sanitized.

Weakness: CWE-674 (Uncontrolled Recursion)

## Which versions are affected by CVE-2022-23516?

2 open source packages ship an affected version, including loofah. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `loofah` | RubyGems | From 2.2.0 | 2.19.1 |
| `loofah` | RubyGems | From 2.2.0 | 2.19.1 |

Products: Loofah Project Loofah.

## How do I fix CVE-2022-23516?

Upgrade loofah to 2.19.1 or later.

## Is CVE-2022-23516 being exploited?

There is no known exploitation of CVE-2022-23516 in the wild and no public exploit code.

## Other vulnerabilities in flavorjones loofah

- [CVE-2022-23514](https://insights.sbomify.com/CVE-2022-23514/): Inefficient Regular Expression Complexity in Loofah (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-23516 and fix it if it is affected.

What it is: CVE-2022-23516 is a high-severity vulnerability in flavorjones loofah, published on 14 Dec 2022. 
Exploitation: There is no known exploitation of CVE-2022-23516 in the wild and no public exploit code.

Affected packages and fixed versions:
- loofah (RubyGems): affected from 2.2.0; fixed in 2.19.1
- loofah (RubyGems): affected from 2.2.0; fixed in 2.19.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-23516/ (Markdown: https://insights.sbomify.com/CVE-2022-23516/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-23516
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-23516
- OSV: https://osv.dev/vulnerability/CVE-2022-23516

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-23516/
Summaries are generated and may contain mistakes; the official description above is the record.
