{"answers":{"affected":"2 open source packages ship an affected version, including rails-html-sanitizer. It affects 2 products.","exploited":"There is no known exploitation of CVE-2022-23519 in the wild and no public exploit code.","fix":"Upgrade rails-html-sanitizer to 1.4.4 or later.","what":"CVE-2022-23519 is a high-severity cross-site scripting vulnerability in Debian Debian Linux, published on 14 Dec 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-23519 and fix it if it is affected.\n\nWhat it is: CVE-2022-23519 is a high-severity cross-site scripting vulnerability in Debian Debian Linux, published on 14 Dec 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-23519 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- rails-html-sanitizer (RubyGems): affected all versions; fixed in 1.4.4\n- rails-html-sanitizer (RubyGems): affected all versions; fixed in 1.4.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-23519/ (Markdown: https://insights.sbomify.com/CVE-2022-23519/index.md)","id":"CVE-2022-23519","markdown":"https://insights.sbomify.com/CVE-2022-23519/index.md","name":"CVE-2022-23519","record":{"aliases":["DEBIAN-CVE-2022-23519","GHSA-9h9g-93gc-623h","UBUNTU-CVE-2022-23519"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":true,"product_category":"Ruby HTML sanitizer","requires_auth":"none","summary":"Attackers can inject malicious scripts via XSS if developers override allowed tags to include style with math or svg elements.","user_interaction":"not_required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"debian_linux","vendor":"debian"},{"product":"rails_html_sanitizers","vendor":"rubyonrails"}],"cvss":{"score":7.2,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"rails-html-sanitizer is responsible for sanitizing HTML fragments in Rails applications. Prior to version 1.4.4, a possible XSS vulnerability with certain configurations of Rails::Html::Sanitizer may allow an attacker to inject content if the application developer has overridden the sanitizer's allowed tags in either of the following ways: allow both \"math\" and \"style\" elements,  or allow both \"svg\" and \"style\" elements. Code is only impacted if allowed tags are being overridden. . This issue is fixed in version 1.4.4. All users overriding the allowed tags to include \"math\" or \"svg\" and \"style\" should either upgrade or use the following workaround immediately: Remove \"style\" from the overridden allowed tags, or remove \"math\" and \"svg\" from the overridden allowed tags.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Possible XSS vulnerability with certain configurations of rails-html-sanitizer","id":"CVE-2022-23519","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":"debian:debian_linux","products":["debian:debian_linux"],"type":"xss","year":"2022"},"n_packages":2,"n_references":3,"next":{"headline":"rails-html-sanitizer contains an incomplete fix for an XSS vulnerability","id":"CVE-2022-23520"},"packages":[{"ecosystem":"RubyGems","fixed":["1.4.4"],"introduced":["0"],"last_affected":[],"package":"rails-html-sanitizer","purl":null,"source":"GHSA-9h9g-93gc-623h"},{"ecosystem":"RubyGems","fixed":["1.4.4"],"introduced":["0"],"last_affected":[],"package":"rails-html-sanitizer","purl":"pkg:gem/rails-html-sanitizer","source":"GHSA-9h9g-93gc-623h"}],"prev":{"headline":"Improper neutralization of data URIs allows XSS in rails-html-sanitizer","id":"CVE-2022-23518"},"products":["rails-html-sanitizer"],"published":"2022-12-14","related":[{"cvss_score":10,"headline":"ProFTPD Improper Access Control","id":"CVE-2015-3306","kev_date_added":"2026-10-08","published":"2015-05-18"},{"cvss_score":9.9,"headline":"RoundCube Webmail Deserialization of Untrusted Data","id":"CVE-2025-49113","kev_date_added":"2026-02-20","published":"2025-06-02"},{"cvss_score":9.8,"headline":"GNU InetUtils Argument Injection","id":"CVE-2026-24061","kev_date_added":"2026-01-26","published":"2026-01-21"},{"cvss_score":9.8,"headline":"Linux Kernel Improper Check for Unusual or Exceptional Conditions","id":"CVE-2025-39682","kev_date_added":"2026-09-18","published":"2025-09-05"},{"cvss_score":9.8,"headline":"Mozilla Firefox Use-After-Free","id":"CVE-2024-9680","kev_date_added":"2024-10-15","published":"2024-10-09"},{"cvss_score":9.8,"headline":"RARLAB UnRAR Directory Traversal","id":"CVE-2022-30333","kev_date_added":"2022-08-09","published":"2022-05-09"},{"cvss_score":9.8,"headline":"Roundcube Webmail SQL Injection","id":"CVE-2021-44026","kev_date_added":"2023-06-22","published":"2021-11-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2025-11-03","vendors":["rails"]},"summary":"Attackers can inject malicious scripts via XSS if developers override allowed tags to include style with math or svg elements.","url":"https://insights.sbomify.com/CVE-2022-23519/"}