# CVE-2022-23519: Possible XSS vulnerability with certain configurations of rails-html-sanitizer

> Attackers can inject malicious scripts via XSS if developers override allowed tags to include style with math or svg elements.

- **Severity:** High 7.2 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Dec 2022
- **Updated:** 3 Nov 2025
- **Also known as:** DEBIAN-CVE-2022-23519, GHSA-9h9g-93gc-623h, UBUNTU-CVE-2022-23519

## What is CVE-2022-23519?

CVE-2022-23519 is a high-severity cross-site scripting vulnerability in Debian Debian Linux, published on 14 Dec 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

rails-html-sanitizer is responsible for sanitizing HTML fragments in Rails applications. Prior to version 1.4.4, a possible XSS vulnerability with certain configurations of Rails::Html::Sanitizer may allow an attacker to inject content if the application developer has overridden the sanitizer's allowed tags in either of the following ways: allow both "math" and "style" elements,  or allow both "svg" and "style" elements. Code is only impacted if allowed tags are being overridden. . This issue is fixed in version 1.4.4. All users overriding the allowed tags to include "math" or "svg" and "style" should either upgrade or use the following workaround immediately: Remove "style" from the overridden allowed tags, or remove "math" and "svg" from the overridden allowed tags.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2022-23519?

2 open source packages ship an affected version, including rails-html-sanitizer. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `rails-html-sanitizer` | RubyGems | All versions | 1.4.4 |
| `rails-html-sanitizer` | RubyGems | All versions | 1.4.4 |

Products: Debian Debian Linux, Rubyonrails Rails Html Sanitizers.

## How do I fix CVE-2022-23519?

Upgrade rails-html-sanitizer to 1.4.4 or later.

## Is CVE-2022-23519 being exploited?

There is no known exploitation of CVE-2022-23519 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-23519 and fix it if it is affected.

What it is: CVE-2022-23519 is a high-severity cross-site scripting vulnerability in Debian Debian Linux, published on 14 Dec 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-23519 in the wild and no public exploit code.

Affected packages and fixed versions:
- rails-html-sanitizer (RubyGems): affected all versions; fixed in 1.4.4
- rails-html-sanitizer (RubyGems): affected all versions; fixed in 1.4.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-23519/ (Markdown: https://insights.sbomify.com/CVE-2022-23519/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-23519
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-23519
- OSV: https://osv.dev/vulnerability/CVE-2022-23519

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-23519/
Summaries are generated and may contain mistakes; the official description above is the record.
