# CVE-2022-23522: Arbitrary File Write when Extracting Tarballs retrieved from a remote location using in mindsdb

> Attackers can overwrite system files by serving malicious tarballs to MindsDB, potentially leading to code execution or data modification.

- **Severity:** High 8.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 Mar 2023
- **Updated:** 12 Feb 2025
- **Also known as:** GHSA-7x45-phmr-9wqp, PYSEC-2023-26

## What is CVE-2022-23522?

CVE-2022-23522 is a high-severity path traversal vulnerability in mindsdb, published on 30 Mar 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

MindsDB is an open source machine learning platform. An unsafe extraction is being performed using `shutil.unpack_archive()` from a remotely retrieved tarball. Which may lead to the writing of the extracted files to an unintended location. This vulnerability is sometimes called a **TarSlip** or a **ZipSlip variant**. Unpacking files using the high-level function `shutil.unpack_archive()` from a potentially malicious tarball without validating that the destination file path remained within the intended destination directory may cause files to be overwritten outside the destination directory. An attacker could craft a malicious tarball with a filename path, such as `../../../../../../../../etc/passwd`, and then serve the archive remotely using a personal bucket `s3`, thus, retrieve the tarball through **mindsdb** and overwrite the system files of the hosting server. This issue has been addressed in version 22.11.4.3. Users are advised to upgrade. Users unable to upgrade should avoid ingesting archives from untrusted sources.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2022-23522?

3 open source packages ship an affected version, including mindsdb. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mindsdb` | PyPI | All versions | 22.11.4.3 |
| `mindsdb` | PyPI | All versions | 22.11.4.3 |
| `mindsdb` | PyPI | All versions | 22.11.4.3 |

Products: Mindsdb Mindsdb.

## How do I fix CVE-2022-23522?

Upgrade mindsdb to 22.11.4.3 or later.

## Is CVE-2022-23522 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-23522 exists.

## Other vulnerabilities in mindsdb

- [CVE-2024-24759](https://insights.sbomify.com/CVE-2024-24759/): MindsDB Vulnerable to Bypass of SSRF Protection with DNS Rebinding (critical 9.3)
- [CVE-2023-50731](https://insights.sbomify.com/CVE-2023-50731/): MindsDB has arbitrary file write in file.py (critical 9.1)
- [CVE-2023-38699](https://insights.sbomify.com/CVE-2023-38699/): MindsDB 'Call to requests with verify=False disabling SSL certificate checks, security issue.' issue (critical 9.1)
- [CVE-2024-45856](https://insights.sbomify.com/CVE-2024-45856/): MindsDB Cross-site Scripting vulnerability (critical 9.0)
- [CVE-2026-27483](https://insights.sbomify.com/CVE-2026-27483/): MindsDB has Path Traversal in /api/files Leading to Remote Code Execution (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-23522 and fix it if it is affected.

What it is: CVE-2022-23522 is a high-severity path traversal vulnerability in mindsdb, published on 30 Mar 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-23522 exists.

Affected packages and fixed versions:
- mindsdb (PyPI): affected all versions; fixed in 22.11.4.3
- mindsdb (PyPI): affected all versions; fixed in 22.11.4.3
- mindsdb (PyPI): affected all versions; fixed in 22.11.4.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-23522/ (Markdown: https://insights.sbomify.com/CVE-2022-23522/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-23522
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-23522
- OSV: https://osv.dev/vulnerability/CVE-2022-23522

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-23522/
Summaries are generated and may contain mistakes; the official description above is the record.
