{"answers":{"affected":"2 open source packages ship an affected version, including linux-loader. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-23523 in the wild and no public exploit code.","fix":"Upgrade linux-loader to 0.8.1 or later.","what":"CVE-2022-23523 is a medium-severity denial of service vulnerability in rust-vmm linux-loader, published on 13 Dec 2022. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-23523 and fix it if it is affected.\n\nWhat it is: CVE-2022-23523 is a medium-severity denial of service vulnerability in rust-vmm linux-loader, published on 13 Dec 2022. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-23523 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- linux-loader (crates.io): affected all versions; fixed in 0.8.1\n- linux-loader (crates.io): affected all versions; fixed in 0.8.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-23523/ (Markdown: https://insights.sbomify.com/CVE-2022-23523/index.md)","id":"CVE-2022-23523","markdown":"https://insights.sbomify.com/CVE-2022-23523/index.md","name":"CVE-2022-23523","record":{"aliases":["GHSA-52h2-m2cf-9jh6"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Rust VM loader library","requires_auth":"none","summary":"A maliciously crafted ELF kernel image can cause Virtual Machine Monitors using the linux-loader crate to enter an infinite loop, resulting in denial of service.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"linux-loader","vendor":"linux-loader_project"}],"cvss":{"score":4,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L","version":"3.1"},"cwes":[{"id":"CWE-125","name":"Out-of-bounds Read"},{"id":"CWE-119","name":"Improper Restriction of Operations within the Bounds of a Memory Buffer"}],"description":"In versions prior to 0.8.1, the linux-loader crate uses the offsets and sizes provided in the ELF headers to determine the offsets to read from. If those offsets point beyond the end of the file this could lead to Virtual Machine Monitors using the `linux-loader` crate entering an infinite loop if the ELF header of the kernel they are loading was modified in a malicious manner. This issue has been addressed in 0.8.1. The issue can be mitigated by ensuring that only trusted kernel images are loaded or by verifying that the headers do not point beyond the end of the file.","ecosystems":["crates.io"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"rust-vmm linux-loader vulnerable to Out-of-bounds Read","id":"CVE-2022-23523","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"crates.io","product":null,"products":[],"type":"denial_of_service","year":"2022"},"n_packages":2,"n_references":2,"next":{"headline":"Helm vulnerable to Denial of service through string value parsing","id":"CVE-2022-23524"},"packages":[{"ecosystem":"crates.io","fixed":["0.8.1"],"introduced":["0"],"last_affected":[],"package":"linux-loader","purl":null,"source":"GHSA-52h2-m2cf-9jh6"},{"ecosystem":"crates.io","fixed":["0.8.1"],"introduced":["0"],"last_affected":[],"package":"linux-loader","purl":"pkg:cargo/linux-loader","source":"GHSA-52h2-m2cf-9jh6"}],"prev":{"headline":"Arbitrary File Write when Extracting Tarballs retrieved from a remote location using in mindsdb","id":"CVE-2022-23522"},"products":["linux-loader"],"published":"2022-12-13","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-18","vendors":["rust-vmm"]},"summary":"A maliciously crafted ELF kernel image can cause Virtual Machine Monitors using the linux-loader crate to enter an infinite loop, resulting in denial of service.","url":"https://insights.sbomify.com/CVE-2022-23523/"}