# CVE-2022-23523: rust-vmm linux-loader vulnerable to Out-of-bounds Read

> A maliciously crafted ELF kernel image can cause Virtual Machine Monitors using the linux-loader crate to enter an infinite loop, resulting in denial of service.

- **Severity:** Medium 4.0 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Dec 2022
- **Updated:** 18 Apr 2025
- **Also known as:** GHSA-52h2-m2cf-9jh6

## What is CVE-2022-23523?

CVE-2022-23523 is a medium-severity denial of service vulnerability in rust-vmm linux-loader, published on 13 Dec 2022. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

In versions prior to 0.8.1, the linux-loader crate uses the offsets and sizes provided in the ELF headers to determine the offsets to read from. If those offsets point beyond the end of the file this could lead to Virtual Machine Monitors using the `linux-loader` crate entering an infinite loop if the ELF header of the kernel they are loading was modified in a malicious manner. This issue has been addressed in 0.8.1. The issue can be mitigated by ensuring that only trusted kernel images are loaded or by verifying that the headers do not point beyond the end of the file.

Weakness: CWE-125 (Out-of-bounds Read), CWE-119 (Improper Restriction of Operations within the Bounds of a Memory Buffer)

## Which versions are affected by CVE-2022-23523?

2 open source packages ship an affected version, including linux-loader. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `linux-loader` | crates.io | All versions | 0.8.1 |
| `linux-loader` | crates.io | All versions | 0.8.1 |

Products: Linux-Loader Project Linux-Loader.

## How do I fix CVE-2022-23523?

Upgrade linux-loader to 0.8.1 or later.

## Is CVE-2022-23523 being exploited?

There is no known exploitation of CVE-2022-23523 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-23523 and fix it if it is affected.

What it is: CVE-2022-23523 is a medium-severity denial of service vulnerability in rust-vmm linux-loader, published on 13 Dec 2022. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-23523 in the wild and no public exploit code.

Affected packages and fixed versions:
- linux-loader (crates.io): affected all versions; fixed in 0.8.1
- linux-loader (crates.io): affected all versions; fixed in 0.8.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-23523/ (Markdown: https://insights.sbomify.com/CVE-2022-23523/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-23523
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-23523
- OSV: https://osv.dev/vulnerability/CVE-2022-23523

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-23523/
Summaries are generated and may contain mistakes; the official description above is the record.
