{"answers":{"affected":"4 open source packages ship an affected version, including helm.sh/helm/v3 and helm. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-23524 in the wild and no public exploit code.","fix":"Upgrade helm.sh/helm/v3 to 3.10.3 or later.","what":"CVE-2022-23524 is a medium-severity denial of service vulnerability in helm, published on 15 Dec 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-23524 and fix it if it is affected.\n\nWhat it is: CVE-2022-23524 is a medium-severity denial of service vulnerability in helm, published on 15 Dec 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-23524 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- helm.sh/helm/v3 (Go): affected all versions; fixed in 3.10.3\n- helm.sh/helm/v3 (Go): affected all versions; fixed in 3.10.3\n- helm.sh/helm/v3 (Go): affected all versions; fixed in 3.10.3\n- helm (Bitnami): affected from 3.0.0; fixed in 3.10.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-23524/ (Markdown: https://insights.sbomify.com/CVE-2022-23524/index.md)","id":"CVE-2022-23524","markdown":"https://insights.sbomify.com/CVE-2022-23524/index.md","name":"CVE-2022-23524","record":{"aliases":["AZL-11654","BIT-helm-2022-23524","CLEANSTART-2026-BS54802","GHSA-6rx9-889q-vv2r","GO-2022-1167"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Kubernetes package manager","requires_auth":"none","summary":"Attackers can cause a stack overflow and denial of service in Helm by providing malicious string values to the strvals package.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"helm","vendor":"helm"}],"cvss":{"score":5.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L","version":"3.1"},"cwes":[{"id":"CWE-770","name":"Allocation of Resources Without Limits or Throttling"},{"id":"CWE-400","name":"Uncontrolled Resource Consumption"}],"description":"Helm is a tool for managing Charts, pre-configured Kubernetes resources. Versions prior to 3.10.3 are subject to Uncontrolled Resource Consumption, resulting in Denial of Service. Input to functions in the _strvals_ package can cause a stack overflow. In Go, a stack overflow cannot be recovered from. Applications that use functions from the _strvals_ package in the Helm SDK can have a Denial of Service attack when they use this package and it panics. This issue has been patched in 3.10.3. SDK users can validate strings supplied by users won't create large arrays causing significant memory usage before passing them to the _strvals_ functions.","ecosystems":["Bitnami","Go"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Helm vulnerable to Denial of service through string value parsing","id":"CVE-2022-23524","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"denial_of_service","year":"2022"},"n_packages":4,"n_references":1,"next":{"headline":"Helm vulnerable to Denial of service via NULL Pointer Dereference","id":"CVE-2022-23525"},"packages":[{"ecosystem":"Bitnami","fixed":["3.10.3"],"introduced":["3.0.0"],"last_affected":[],"package":"helm","purl":"pkg:bitnami/helm","source":"BIT-helm-2022-23524"},{"ecosystem":"Go","fixed":["3.10.3"],"introduced":["0"],"last_affected":[],"package":"helm.sh/helm/v3","purl":null,"source":"GHSA-6rx9-889q-vv2r"},{"ecosystem":"Go","fixed":["3.10.3"],"introduced":["0"],"last_affected":[],"package":"helm.sh/helm/v3","purl":"pkg:golang/helm.sh/helm/v3","source":"GHSA-6rx9-889q-vv2r"},{"ecosystem":"Go","fixed":["3.10.3"],"introduced":["0"],"last_affected":[],"package":"helm.sh/helm/v3","purl":"pkg:golang/helm.sh/helm/v3","source":"GO-2022-1167"}],"prev":{"headline":"rust-vmm linux-loader vulnerable to Out-of-bounds Read","id":"CVE-2022-23523"},"products":["helm"],"published":"2022-12-15","related":[{"cvss_score":9.8,"headline":"Helm Unsafe Link Following","id":"CVE-2019-18658","kev_date_added":null,"published":"2019-11-12"},{"cvss_score":9.8,"headline":"Helm Improper Certificate Validation","id":"CVE-2019-1010275","kev_date_added":null,"published":"2019-07-17"},{"cvss_score":9.1,"headline":"Information disclosure in n/a","id":"CVE-2019-25210","kev_date_added":null,"published":"2024-03-03"},{"cvss_score":8.5,"headline":"Helm Chart Dependency Updating With Malicious Chart.yaml Content And Symlink Can Lead To Code Execution","id":"CVE-2025-53547","kev_date_added":null,"published":"2025-07-08"},{"cvss_score":8.5,"headline":"lookup Function Information Discolosure in Helm","id":"CVE-2020-11013","kev_date_added":null,"published":"2020-04-24"},{"cvss_score":8.4,"headline":"Helm has a path traversal in plugin metadata version enables arbitrary file write outside Helm plugin directory","id":"CVE-2026-35204","kev_date_added":null,"published":"2026-04-09"},{"cvss_score":8.4,"headline":"Helm's plugin verification fails open when .prov is missing, allowing unsigned plugin install","id":"CVE-2026-35205","kev_date_added":null,"published":"2026-04-09"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"Go Vulnerability Database","prefix":"GO"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-18","vendors":["helm"]},"summary":"Attackers can cause a stack overflow and denial of service in Helm by providing malicious string values to the strvals package.","url":"https://insights.sbomify.com/CVE-2022-23524/"}