CVE-2022-23525 Helm vulnerable to Denial of service via NULL Pointer Dereference
Attackers can cause a denial of service in Helm by providing a malformed repository index file that triggers a null pointer dereference panic.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2022-23525?
CVE-2022-23525 is a medium-severity vulnerability in helm, published on 15 Dec 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Helm is a tool for managing Charts, pre-configured Kubernetes resources. Versions prior to 3.10.3 are subject to NULL Pointer Dereference in the _repo_package. The _repo_ package contains a handler that processes the index file of a repository. For example, the Helm client adds references to chart repositories where charts are managed. The _repo_ package parses the index file of the repository and loads it into structures Go can work with. Some index files can cause array data structures to be created causing a memory violation. Applications that use the _repo_ package in the Helm SDK to parse an index file can suffer a Denial of Service when that input causes a panic that cannot be recovered from. The Helm Client will panic with an index file that causes a memory violation panic. Helm is not a long running service so the panic will not affect future uses of the Helm client. This issue has been patched in 3.10.3. SDK users can validate index files that are correctly formatted before passing them to the _repo_ functions.
Weakness: CWE-476
Which versions are affected by CVE-2022-23525?
4 open source packages ship an affected version, including helm.sh/helm/v3 and helm. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
helm.sh/helm/v3 Go | All versions | 3.10.3 |
helm.sh/helm/v3 Go | All versions | 3.10.3 |
helm.sh/helm/v3 Go | All versions | 3.10.3 |
helm Bitnami | From 3.0.0 | 3.10.3 |
Linux distribution packages (1)
cmctl openSUSE:Tumbleweed | All versions | 1.10.2-1.1 |
Products include Helm Helm.
How do I fix CVE-2022-23525?
Upgrade helm.sh/helm/v3 to 3.10.3 or later.
Is CVE-2022-23525 being exploited?
There is no known exploitation of CVE-2022-23525 in the wild and no public exploit code.
Other vulnerabilities in helm
- CVE-2019-18658 Helm Unsafe Link Following
- CVE-2019-1010275 Helm Improper Certificate Validation
- CVE-2019-25210 Information disclosure in n/a
- CVE-2025-53547 Helm Chart Dependency Updating With Malicious Chart.yaml Content And Symlink Can Lead To Code Execution
- CVE-2020-11013 lookup Function Information Discolosure in Helm
Sources
Also known as AZL-11655, BIT-helm-2022-23525, CLEANSTART-2026-SX42881, GHSA-53c4-hhmh-vw5q, GO-2022-1165, openSUSE-SU-2024:12603-1.